Please do not post a support request without first reading and following the advice in

Retro Pie 4.2 PSX "Bios not found"

  • Hello I recently built a Retro Pie with a raspberry pie 3 and have followed all instructions to the latter. But for some odd reason everytime I start a psx game I get the "bios not found expect bugs" message and the problems that entails.

    I have been using a Usb to transfer roms and have looked all over the internet and tried different things including. Renaming files, trying different BIOS, updating emulators everything except stuff that involves messing with command lines as I am afraid of breaking something.

    The only thing I can think of what could have done this is that I had to move my sd image to a new sd card other then that I dont know why this is happening. So im asking is there anything I did wrong? Is there a bug or can I not actually transport bios through usb I would be gratefull for any help.

    (Sorry for any formatting issues I typed this through mobile)

  • @Skull-Knight The information you're providing isn't particularly detailed, in terms of allowing us to suggest things and troubleshoot them.

    Are you saying you're mounting a USB drive as your ROM folder? Where is it being mounted (i.e. ~/RetroPie? ~/RetroPie/roms?).

    The BIOS should be copied to ~/RetroPie/BIOS . I can't say more without knowing what is happening there, other than I do not seem to have such problems. The wiki page suggests some MD5/SHA1 hashes for the BIOS files, in case you want to check whether you're using a correct one, though I've found - as well as others - that other BIOS files work similarly well.

    Best of luck.

  • @Skull-Knight Im going to take a stab in the dark and assume you are trying to play the ps1 berserk game?

  • Same issue. RetroPie is installed on a Pi3, ROMs are on a USB flash drive formatted to FAT32.

    ROMs are in retropie/roms/psx
    The emulator sees without issues:
    CTR - Crash Team Racing (USA).bin
    CTR - Crash Team Racing (USA).cue

    BIOS files are in retropie/BIOS

    I've tried:

    Keep getting the same error, "bios not found expect bugs".

    Any ideas?

  • You have to make sure that the .bin files you are uploading have lowercase letters and their MD5 checksum are correct.

    PSX scph5500.bin 8dd7d5296a650fac7319bce665a6a53c
    PSX scph5501.bin 924e392ed05558ffdb115408c263dccf
    PSX scph5502.bin e56ec1b027e2fe8a49217d9678f7f6bb

    Once the checksums are similar, you can just rename the .bin files. This was how I got my BIOS working last night.

  • @nehal1802
    Make sure it's in /home/pi/RetroPie/BIOS

    More info:

    Transfer by sftp or any other means to get to that folder.
    Bios names don't need to be in caps. You also just need one of them. Any psx bios that's not listed in the wiki will also work.

  • @nehal1802 and @Skull-Knight

    Please share exactly how your USB drive is mounted. What are the contents of fstab?


  • @Darksavior

    Upon looking in the file manager at /home/pi/RetroPie/
    I have found that the BIOS folder is missing is there anyway to create a new folder or will I have to re-install retro pie?

  • @Skull-Knight You can certainly create it, but as I asked before, can you share the contents of your fstab file for mounting?

    You may be mounting at the wrong mount point. I expect you will have an actual BIOS folder, but it's being hidden as you may be mounting your USB drive on the RetroPie folder.

  • @pjft
    Im sorry I am new to all this can you explain what fstab is? and where I can find it.

  • @Skull-Knight Sure.

    In the command line at your Pi / via SSH, type

    cat /etc/fstab

  • Global Moderator

    i'm guessing, but i don't think either are running roms from USB, but rather using it to transfer via

    i'm not sure if this works to transfer BIOS files.. someone else said as much in another thread (can anyone confirm). if it doesn't, you'll have to use SFTP or samba transfers via wireless or a network cable.

    (or you could copy it from the stick via the linux commandline, but that requires a bit more explanation)

  • @pjft
    upon looking I have received an almost exact replica of what appears in the fstab section of this page.

  • This post is deleted!

  • @Skull-Knight Can you confirm the exact line of your USB mount point?

    Is it something like

    UUID=<drive ID> /home/pi/RetroPie      vfat    nofail,user,uid=pi,gid=pi 0       2


    If so, it means you're mounting on the RetroPie folder - just like me, so I know the set up.

    It means your BIOS folder is currently in the SD card, but you're mounting over it.

    You could certainly create a new folder on your USB drive, but the standard BIOS folder will usually already have some required BIOS files there.

    My recommendation, as awful as it may seem, is:

    1. Boot your Pi without your USB drive there
    2. Now, as you navigate to the BIOS folder you will see one there
    3. Plug in a second USB drive (not THAT one you're using) and copy the BIOS folder to it
    4. Now copy the BIOS folder from that USB drive to the one you're using
    5. Restart your Pi with the USB drive plugged in

    If that's not the case at all (i.e. if you're just doing what @dankcushions is suggesting) then, sure, you may just create a BIOS folder there, but I'm struggling to figure out why the folder would not exist there in the first place.

  • @pjft

    The only reason I can think of as to why the bios folder is not there is because I had to move everything to a new SD card as I ran out of space on the old one and maybe as it was moving everything for some reason it skipped on the bios folder.

  • @Skull-Knight Yeah, that could have been it then. I'd hope (unconfirmed) that if you go to the RetroPie-Setup script and update/install all packages again, the folder will be created... maybe?

    Try it with the PSX emulator, see if it creates it. But yes, you can create it yourself - and, as long as you don't run into problems with other emulators, I suppose you'll be fine-ish. But yeah, if any emulator doesn't behave as expected, I'd suggest it could be related to that.

  • @pjft

    Ok I just looked back in the file manager and have found that the BIOS folder has reappeared inside the folder is


    I have no idea how the folder came back or if it was there all along and I was dumb enough not to see it but it still does not explain why the psx bios wont work.

  • @Skull-Knight Well, it does, right?

    I don't see any PSX Bios file in it :)

  • Ohhhhh that explains it how do I create a psx bios folder?

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.