Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

N64 Emulators (maybe more) keyboard input not working



  • Hey everyone, created an account to post this since /r/retropie is far less active and the thread didn't get any comments.

    I have the latest version of Retropie as of now(4.2) installed on my Raspberry Pi 3 Model B, and a lot of the emulators for the really old consoles like GBA work fine input wise, but when trying to play, for example Mario Kart 64, on any of the N64 emulators it just does not receive any input, apart from the few system keys, like ESC, P to pause, and "/" (Mupen64Plus)

    • I'm using a wireless USB keyboard.

    • Input works completely fine with many older systems like GBA, MAME

    • Keyboard doesn't seem to register anything else once I start up for example Mario Kart 64 other than standard system keys like P and ESC.

    I've tried the following:

    • Searched all over the internet if there was anyone with a similar problem (some fixes included editing files that were only in earlier versions of Retropie, but I didn't find many people with the same issue at all)

    • Gone into /opt/retropie/configs/n64 and messed around with the mupen64plus.cfg, with the controller config mode, i tried fully manual (setting the keyboard keycodes (see this, scroll down to point 3 where it says "See http://www.libsdl.org/release/SDL-1.2.15/include/SDL_keysym.h for Key IDs.") myself), auto with named SDL device, and of course, the standard option, fully automatic.

    • I've also gone into /opt/retropie/configs/all/autoconfig.cfg and everything seems to be fine there as well.

    I put "maybe more" in the title, as I have a similar issue with the Dreamcast emulator. Sonic Adventure boots fine like it's supposed to, but if I press anything at all on my keyboard, it just writes as terminal text on the bottom of the screen. Aka the key presses once again did nothing in the game itself. The exit key for the emulator thankfully did work though. I put this issue at the end, because I have not done much research about this one yet, but I would highly appreciate if anyone could help me with this too.

    I'm really pumped about the project I am currently working on which is my own take on a handheld RPi3 B+ console, and actually being able to play the games is quite important I'd say!
    If anyone needs more info about anything I'd love to tell. Thanks in advance guys!

    • Info:
      • Raspberry Pi 3 Model B
      • Retropie 4.2
      • Power supply is a micro USB cable
      • Built from pre-made SD card image on Retropie website
      • USB Devices connected: Logitech Wireless USB Keyboard
      • Controller: Logitech Wireless USB Keyboard
      • Emulator: Any N64 Emulator


  • I have the same problem, but I still have no idea why it doesn't work


  • Global Moderator

    I see your problem. Keyboard configuration is not implemented atm. Default keyboard settings will only be set if joypad configuration runs once.


  • Global Moderator

    @wack26
    Pleas update RetroPie-Setup and install mupen64plus again. Keyboard should work now.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.