Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

SegaCD page is out of date on Wiki



  • I think the SegaCD page is out of date with regard to BIOS file naming for Picodrive. It says that the BIOS files need to be called us_scd1_9210.bin, eu_mcd1_9210.bin & jp_mcd1_9112.bin but this isn't the case.

    If you look at the /opt/retropie/configs/all/retroarch/cores/picodrive_libretro.info, you can see that the file names it expects are: bios_CD_E.bin, bios_CD_J.bin & bios_CD_U.bin (as per Genesis Plus). And if you only have files named as such in your BIOS folder, the SegaCD games still launch.

    To prove this, move all the SegaCD BIOS files into a temporary subdirectory (to prove that games no longer launch) and then move only the Genesis Plus BIOS files back into the main BIOS directory. Then launch a SegaCD game under Picodrive.

    I would have posted an issue in GitHub to get the Wiki changed, but the new issue template recommended I post here first to check.


  • administrators

    @RobotLimeLtd I was basing it off libretro's wiki. So if someone can confirm then a change may be in order but last I tested it was what it was listed in the wiki unless something has changed since then



  • @RobotLimeLtd Another thing I discovered this evening (which I have a separate post about). it appears that Picodrive and Genesis Plus now require the BIOS files to be in the same directory as the roms.

    When I launch a game in verbose mode, I see the following in the log:

    RetroArch [INFO] :: Environ SYSTEM_DIRECTORY: "/home/pi/RetroPie/roms/segacd/".

    I have checked and my main retroarch.cfg has system_directory as "default" (which I presume means each emulator uses its own setting).



  • @RobotLimeLtd are you sure System Directory stands for the BIOS folder? I thought it'd be the directory where there games are?

    Edit: nevermind, I stand corrected.


  • administrators

    @RobotLimeLtd That is not the default for retropie - default retropie has

    # Sets the "system" directory.
    # Implementations can query for this directory to load BIOSes, system-specific configs, etc.
    system_directory = "/home/pi/RetroPie/BIOS"
    

    in configs/all/retroarch.cfg - perhaps you overwrote the config?



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.