Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Upgrading psx graphics through retroarch



  • Bit of a newbie. Got really pixelated graphics on raspberrypi 3 running Retropie, especially psx games. I watched a few youtube vids explaining how to upgrade it via Retroarch menu but Retroarch doesn't have the options anywhere.. says at the bottom (1.3.6 No core). I also seen a way to change the config file..but again mine doesn't have the graphics info to change. Any ideas are appreciated


  • administrators

    @epd depends on the renderer you're using and the emulator I use libretro Beetle hw with the Vulkan renderer but it only works on pc. There's probably some texture packs of sorts on lr-pcsx-rearmed or whatever it's called. O haven't really used it answer is probably on the docs though. Have you read them?



  • 0_1493857088528_18222499_10159104001845112_7091469978881030448_n.jpg

    Yes but i didn't find anything. Im at this menu now, not too sure what to change here but at least it seems like a start. Would changing any of these improve quality?


  • administrators



  • @epd if you press select and x while in a game you get into the rgui. Go to quick menu then options. Set enhanced resolution (slow) to "enabled" do not enable enhanced resolution speed hack. It will randomly lock up the system. Works on a pi 3 without it for me. then you can open up /opt/retropie/configs/psx/retroarch.cfg and add this above the #include.... line:

    video_smooth = "true"


  • Changed enchanced resolution to slow, how do i open up retroarch config? not sure when it comes to commands, I've got a keyboard here do i need it?



  • @epd just go to the retropie menu. Go into configuration editor. Choose option 1. Go down to "configure additional options for psx. Set video smoothing to true.



  • On the pic i posted its already set to true. Slighlty better i think.. but still very pixelated



  • @epd which game are you testing on? Some games like fear effect have a fake background so only the character looks better. Metal gear solid has a real background so the whole screen improves with the enhanced resolution turned on.



  • Twisted Metal, im playing on a 40 inch screen so maybe thats the real problem



  • @epd probably. I am on a 15" screen and it is a noticeable change. Try fear effect. When in a game the character is really noticeable because the background is crap so the charater looks good compared to it when you turn on the enhaced mode.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.