Please do not post a support request without first reading and following the advice in

Can't Delete Files or Folders

  • I am running MacOS 10.12.4 and using latest version of Cyberduck as my SFTP client. Retropie version is 4.2 on raspberry Pi 3.
    When I try to remove any file or folder i get a Denied error. If I look at the bottom of my open screen I see a closed lock symbol. I cannot unlock it by clicking on or if I try to set permissions to 777 it denies it also.
    What am I doing wrong? I was able to remove items in past before 4.2.

  • @Everett1954 Seems like some permissions changed. I wasn't able to delete files/folders over network too. Sometimes the partitions mounted as only read, which I assume is wrong. A restart/remount fixed it and for the delete part I used ssh/console to remove them with root

  • I have tried restarting/remounting and different SFTP clients but I still am not able to delete files and folders?

    It must have something to do with the 4.2 image?

    Is there anyone else that uses a Mac to SFTP into there 4.2 pie? Same results? workaround?

  • I have a Windows PC and same problem I can't delete files or folders and I'm using retropie 4.2. But on a older build not sure what version of retropie I can delete so it must be retropie 4.2!

  • I'm using a SFTP program on Windows (winSCP) too and it works fine for retropie 4.x
    Not sure why it isn't working for you

  • try DuplicateFilesDeleter program

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.