Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

resolution for original gamboy size



  • Hello, I am working on a gameboy zero using a Pi Zero and a waveshare32b display with 320 - 240 resolution.
    everything works fine but I would like to reduce the resolution to the size that it will match with the borders of the gameboy classic. When I edit the config.txt to a resolution of 160 - 144, it gets the resolution only for retropie but doesn't affect emulationstation. also what are the best settings to have the roms also working with that resolution? It is also important that the aspect ratio is always 4:3.

    I appreciate any help.


  • Banned

    @ZEL-SK8 I'm not surprised no-one has replied. You are actually asking about 6 different questions there, whether you realise it or not. I would stick to asking specific questions, nobody wants to write a dissertation in response to a 3 line question.



  • you are right, thank you.

    The one thing I would like to know is how to set the resolution to 160 - 144 in the config.txt so it will also affect emulationstation.



  • okay now I think I have a much clearer understanding of what I realy need.
    I added these lines to my config.txt:

    hdmi_drive=2
    hdmi_force_hotplug=1
    hdmi_group=2
    hdmi_mode=16

    they get emulationstation to boot with the aspect ratio of 4:3. which is exactly what I want to achieve. The only problem is, that it only sets this aspect ratio on my tv which is connected via HDMI. The waveshare32b on the other hand is still showing a 16:9 aspect ratio. I already tried to set the hdmi_group and the hdmi_drive to 1 but without succes.



  • @ZEL-SK8 hdmi mode 16 with group 2 is 1024x768 resolution. That wont work on an lcd with a 320x240 max resolution



  • so which settings should I use?
    I'm just doing try and error...



  • @ZEL-SK8 here are the waveshare32b settings for 320x240. Mode 87 is for 320x240 i believe. Not sure what it would be for what you want. You could try just changing the 320x240 settings to the resolution you want.

    #Waveshare 3.2 TFT Screen
    #same resolution for hdmi and tft
    hdmi_force_hotplug=1
    hdmi_cvt=320 240 60 1 0 0 0
    hdmi_group=2                
    hdmi_mode=1                 
    hdmi_mode=87                
    
    dtparam=spi=on              
    dtoverlay=waveshare32b:rotate=270,speed=82000000


  • @ZEL-SK8 you do need some files i believe. Follow this guide. Scroll down to the 32b

    https://github.com/recalbox/recalbox-os/wiki/TFT-Screen-SPI-Bus-(EN)



  • alright, thank you very much. I am now able to change the resolution of my waveshare.
    but the aspect ratio doesn't change at all. eve though I specify the aspect ratio in the hdmi_cvt-argument



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.