Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Shanwan Mame4all fire button is select not a or x button



  • Hi,
    I have just started using retropie and I'm having trouble remapping a PS3 generic Shanwan bluetooth gamepad. I'm running Mame4all on retropie v4.2 on a RP3.
    For some reason the fire / shoot button is the 'select' button on the Shanwan.
    I also have a PS3 USB only generic gamepad which works correctly with the fire/shoot button being the 'a' or 'x' button depending on the game.
    The LH Analogue Jogstick on the Shanwan is working correctly on the games.
    I have tried to remap the Shanwan within the game by pressing tab key on a USB keyboard and going into the input settings but can't find any setting which I can relate to fire or shoot.
    I have also tried going into the file opt/retropie/configs/all/reroach-joypads and altering it to match the settings on the Sony PLAYSTATION 3 controller file but it didn't make any difference.
    When I initially setup the Shanwan in Emulation Station - configure input the buttons seemed to be correctly detected, so I'm assuming the gamepad is working correctly, but something seems to be lost in Mame4all.
    I can't work out why the Shanwan is behaving differently to the USB PS3 gamepad. I can only assume it's related to the PS3 Shanwan driver that has been loaded.
    I have been through numerous posts but can't seem to find anyone else experiencing this issue, so I can only assume its user error!

    Thanks for your help.



  • @uptime Hi,
    I have managed to resolve the issue.
    I used the Tab key inside the game and selected input settings.
    The fire / shoot button corresponds to button 1. Just hit enter on the keyboard after selecting P1 button 1 and hit x on the Shanwan PS3 generic.
    Thanks.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.