Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

(SOLVED) Retropie Beginner needs advices ! ;) (Gamepads not Detected)



  • Whoops sorry, i Edited it ! Thank you !



  • @Kiirokun I believe the problem lies with your power supply. Phone chargers are not recommended for use as power supplies but they may work and the device may boot. However, start doing some work and add a few peripherals and your 1A charger is unlikely to be up to it. Take a look at
    https://www.raspberrypi.org/help/faqs/#powerReqs and read at the bottom of the list - recommended 1.2A. Some phone chargers are not regulated for use in powering devices. You could find unpredictable behavior happening. The official 2.5A psu is good for all things pi and gives you lots of headroom.



  • I agree with the assessment. Phone chargers are not stable and when they are overloaded they cannot keep up with the demands and then you will experience voltage dropouts. Majority of the problems that are encountered in this forum, especially for first time users, are: inadequate power supply and/or the power supply cables are not suited for Rpi use.



  • Oww thank you rbaker and ortsac !
    I think you're right, but it's incredible to think that just a little difference of power can do that !
    I'll try with a better one !



  • Hello there !
    Sadly the problem is not the power supply, i got suited one and my controllers are still not detected...
    Do you have an other idea ? Thank you for replying.



  • After you power it up, how far does it go when it boots up? What do you see on the screen? Need a little more details on the problem....



  • Well, when i power it up, there is a classic screen with a raspberry on the top-left corner, a list of processes scroll down with a green "OK" for each, then after 5 seconds a screen with the logo "Retropie" appears during 15 seconds, then the list reappears and continue scrolling down, then the "Emulation station" screen appears, and finally i'm on a screen with a banner "retropie" in the middle, just below a "configuration" banner, and on the bottom- left corner there is 3 options "menu" "select" and "choose", i already tried to plug in several controllers but they are not detected, even if i do "configure input", my keyboard is the only one working.

    • I have to plug my keyboard out and in to make the Pi detect it once powered up.
    • On my Pi there is : a Micro USB to USB for the Power and for the USB HUB, a Micro HDMI to HDMI, a MicroSD card, and that's it !

    Thanks for the reply



  • Have you tried to reimage your sd card and install it from scratch? You could also try to reinstall everything from RetroPie-Setup script. Maybe there is something wrong with some drivers or some additional software. Use your keyboard, get into retropie setup, then go to main and core plugins and find whether there is something about controllers or usb drivers. Try to update/reinstall it before doing reimage.



  • Hey ! I don't know what 'Scratch' is, i'm really a beginner ! ^^"
    I'm actually looking for some controllers options, i'm in the "raspberry pi software configuration tool", but i think i don't have to change something !



  • Okay everyone, thank you for your help, i did it !!
    Now, i know that a Cheap USB HUB is not a good idea ! x)
    I bought a new one, not really more expensive, and Tada !

    Thanks for everything !



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.