Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

No input in games



  • Pi Model or other hardware: 3 B
    Power Supply used: 5V phone charger
    RetroPie Version Used: 4.2.7te
    Built From: On top of raspbian
    USB Devices connected: Wireless keyboard
    Controller used: Wireless XBOX 360 controller & Wireless Steam controller
    Error messages received: None
    Emulator: tested on snes9x2005, mgba, and picodrive
    Attachment of config files: (PLEASE USE PASTEBIN.COM FOR LARGE LOGS)

    Both my Xbox 360 and steam controllers work in emulation station perfectly, however when I start any game (used sonic 3 & knuckles, a link to the past, kirby and the amazing mirror, and super mario world and got error on all of them) on any system I can see the messages in the corner saying the controllers are configured in port #X, but there is no input on either controller and the hotkey button doesn't respond either.



  • Hi @bengdahl

    Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

    Complete the requested information table in there first. Also you will need to tell us, which systems, which games, which emulators you are using.



  • Thanks for updating your post with that information. I know that from using the official Retropie image, that a wired XBox360 controller is natively supported. Given you have installed on top of your own copy of Rasbian, there may be other software that is running, for instance are you running Xpad or a similar driver for the controllers outside of RetroPie?

    I assume you are using the libretro emulators from the "Controller configured in port" message. If this is the case, it seems like somehow the controller configuration hasn't been passed to the RetroPad settings in libretro. A quick check, if you press HotKey + Start (or select + start) does the emulator close? It may be worth deleting your controller configs and recreating them.

    I'm not an expert by any stretch, but I try to assist where possible. I have very little experience with loading it over a Raspbian install.
    Have you tried writing the official image to an SD card? If so, do you get the same issues? This will help eliminate if it is something in RetroPie or something in your Raspbian install.



  • @simonster I tried Hotkey+Start, but that didn't work. I will try to remake the configs when i get the chance. I'm not able to use the image though because I am using the Pi for other projects and I don't have a spare SD card, but thanks for the help regardless.



  • @bengdahl

    Fair enough, you could always try the other way around. Install the official image and the add Pixel from the optional components. From there you have both Retropie and access to the Raspbian desktop environment.



  • @simonster

    Okay, I deleted keymaps and remade them in emulation station, now the keyboard works but the controllers still don't work. I checked for programs running on startup but couldn't find anything that might interfere with controllers.



  • @bengdahl

    Could you please post your ~\configs\all\retroarch.cfg to pastebin and post a link here.





  • @bengdahl I think your issue is to do with the fact that you are powering the Pi with a phone charger. You need at least 2.5A for a Pi 3 with peripherals added. Phone chargers aren't designed to power. It may work it may not. What is it rated at?



  • @bengdahl

    Hi, you seem to have a very odd retroarch.cfg. Every controller map is set to nul

    Do you have a retroarch.cfg.rp-dist file in the same folder? If so rename your existing config and copy the rp-dist file to retroarch.cfg. and try again.



  • @simonster
    The controller configs are placed in a different folder, here's my X360 config:
    https://pastebin.com/ULpWweWS



  • @rbaker It is rated for 2A at 5V



  • @bengdahl you need a minimum of 2.5A for correct operation.



  • @bengdahl Did you ever find a solution for this? I'm having the exact same problem.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.