Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Pauses on disk based games.



  • Pi Model or other hardware: 3
    Power Supply used: 2.5a official pi power supply
    RetroPie Version Used 4.2.18
    Built From: Pre made SD Image
    USB Devices connected: controller and USB memory stick for roms
    Controller used: PS3 and various USB
    Emulator: lr-pcsx, lr-genplus gx and lr-beetle-Pce fast

    Recently I've been noticing pauses, where the game just does nothing for a few seconds, on PlayStation games no matter the format. Yesterday while playing a sega cd game, same thing, And just tonight, for the first time rondo of blood on pcengine cd did it. I dont know if there is an issue with retro arch itself or raspian. But it feels like it's not buffering fast enough and it is waiting to load data. This is very recent and only in the last couple weeks. Any ideas? Other than starting over with a clean build.



  • @lostless what formats are the games you tried on both systems? Bin/cue/mp3, bin/cue/wav, iso/cue?



  • @lostless also what all is hooked up to your pi?



  • @edmaul69 oh all sort of formats. For ps1, Pbp ISO and bin/cue.
    Sega cd is in bin/cue and ISO/cue
    And pcecd is all bin/cue.
    It's happening on both my pis with different type of controllers and differ t brand memory stcicks and sd cards. Happens with Bluetooth controllers or just usb.
    The only thing the same between the 2 is mausebwrry switch . But that's been no issue up to a couple weeks ago



  • Did an update to retropie today and it seems to have fixed the issue. Beats me



  • @lostless

    Been a long time since I visited here. So, retropie has been updated recently and that fixed this issue ?



  • @dd-indeed I'm assuming so. Haven't had an issue with the latest build.



  • @lostless

    Allright, gotta test it out today, just finished reformatting my USB stick. Decided to revert from NTSC back to the regular FAT32, because with NTSC, saving savestates on PS1 games took well over 30 seconds to save.



  • Okay, after updating the Retropie and the assets, the pauses vanished and everything seems to work faster and more reliably. Also, when I changed back to the FAT32 format, custom spashscreens started to work again as intended. NTSC fileformat is not good for this system, as it seems to have a sort of slow request on certain actions, meaning that the Raspberry skips the custom splashscreen loading, if the filesystem on the memory device is too slow or not responding quickly enough.



  • Edit: Gotta correct that previous message. The issue is still there, but it's not as frequent as it used to be. Usually driving games are the ones that does it, as they require constant loading of the map as you progress. So maybe the issue lies within that aspect.



  • @dd-indeed for psx in the retroarch core options, did you disable vibration? That might help the psx system.



  • @edmaul69

    Disabling Vibration helps with this kind of issue ?



  • @dd-indeed Lr-pcsx-rearmed has an issue that when the game is supposed to vibrate even if your controller doesnt have vibrate it causes the game to lag. So it is worth turning it off then test.



  • @edmaul69

    Is it enough, that it's disabled from the Retroarch menu and saved as global and game specific config config ? Because I've done that already ages ago, since I don't have rumble on these Dual Analog-controllers I have.



  • @dd-indeed in the retroarch gui did you go into quick menu, options and turn it off there?



  • @edmaul69

    Yes I did, long time ago already.





  • I had this issue a few months ago and was able to fix it. You can clearly see the freeze in games like Silent Hill and Apocalypse where the levels are streamed in chuncks.

    In my case, I was using a 1TB USB HDD so the fix that I found may not work for USB sticks. By default, USB HDDs spin down after a certain amount of seconds, so when you are running in Silent Hill and reach the point where it needs to stream the next segment of the level, the game freezes for half a second waiting for the hdd to "wake up" again.

    The fix was to install a program called "hdparm". With this, I disabled the "sleep" function of the HDD completely, so it ran at 100% all the time. Never had an issue with any CD based game ever again. It was not a retroarch nor raspbian issue.

    I don't know if USB sticks have a "sleep" mode, yours is probably not fast enough.



  • @peridot not sure how i missed him saying it was a usb stick when i read the post. But yeah i think i would have to agree with you.



  • FWI all, just installed retropie x86 and got the same pauses. So i think its a retroarch issue. I haven't seen it recently on the pi.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.