Please do not post a support request without first reading and following the advice in

FBA: Some games requiring accessing RGUI menu to run full speed

  • Pi Model or other hardware: Pi3
    Power Supply used: 5v,2.1a
    RetroPie Version Used (eg 3.6, 3.8.1, 4.1 - do not write latest): 4.2.18
    Built From: Premade SD, plus updates

    Just noticed an issue with a couple of FBA games, Strikers 1945 II and Strikers 1945 III, and am curious if this may also affect other games.

    They run slow, however, when using the RGUI menu to overclock the emulator CPU, they run much faster. When exiting game and re-entering, the game is slow again until the value of CPU overclock is adjusted, either up or down, it doesn't matter. This is despite the fact that the CPU overclock setting is saved between sessions (i.e. if I set it to 140, exit and re-enter, it is still 140. But it will run slow until I change the value of this number, even if I change it to 130). I even used the option to create a game-specific configuration file, but it made no difference.

    Any thoughts or ideas about working around this?


    EDIT 2: A setting does not even have to be changed. Just have to enter the RGUI after game is started, go to "Quick Menu", then "Options", then change a parameter, even if you just change the option and return it back to normal (without any change). Then exiting the RGUI menu makes the game full speed again. Thinking this may be a bug now.

    EDIT: It appears it's not just the overclock setting. As long as any setting at all is changed under the options, the game speed returns to normal.

  • Anyone able to reproduce this?

  • Did you try disabling the rewind feature in retroarch ? Also, what's the clock settings on your pi3 ?

  • Okay, tracking the problem down after finding another game with the same issue. So far, it's s1945iii, s1945ii, and soldivid. All of which are running under Final Burn Alpha.

    The problem only lies with the games by Psikyo, so far. In the RGUI->Quick Menu->Options is an option called Psikyo/Kaneko SH2 mode. It has the options "fast" or "accurate". I set mine on "fast" long ago, but it looks like the setting is not preserving between games, even though when first getting to the menu it says "fast". When set to "accurate", the game is slow. When set to "fast", you must go to the menu and fiddle around (even not changing anything), then exit for the "fast" setting to be active.

    Now to look for a workaround.

  • @barbudreadmon Rewind is disabled, clock settings are stock, with CPU governor set to performance. GPU overclocked to 500 with overvolt of 2.

    Thanks for your input!

    Edit: Just noticed while online searching, you're the one who made the SH2 fix?! Great news!

  • I would try overclocking the cpu to 1300/1350 if i were you. Also, s1945ii/s1945iii run on a different hardware which is not using the sh2 cpu, so the psikyo/kaneko sh2 speedhack shouldn't affect them.

  • @barbudreadmon Overclocked before, had issues with heat though, may play around with it again in the future. While it may help here, it runs full speed just by changing the setting, which is what led me to believe that the setting wasn't being preserved.

    Just tested s1945ii/s1945iii again. The speedhack setting is definitely affecting them. Huge difference between accurate and fast. You do good work, my friend :)

  • Oh you are right, s1945 and s1945p don't run on sh2, but s1945ii/s1945iii do

  • @barbudreadmon Is it possible that the code responsible for initiating the parameters has not been updated to initiate your sh2 fix?

  • @jell said in FBA: Some games requiring accessing RGUI menu to run full speed:

    @barbudreadmon Is it possible that the code responsible for initiating the parameters has not been updated to initiate your sh2 fix?

    I wrote both, they should work properly. That's not exactly a "fix", it's just skipping some sh2 timers to allow games to run faster (most games using this cpu didn't use those timers), that's why it is not enabled by default. Only psikyo's soldivid and kaneko suprnova games are supposed to use those timers, never noticed any issue with soldivid with the speedhack though. I have been thinking about making the speedhack the default for psikyo games for some time now.

  • You got me curious with this. Initially I thought I could reproduce this but after saving the game specific core file, enabling the fix and seeing region to international it seems to always work for me.

    Are you sure you have your options set to load that config file for the game?

    Settings > Configuration > load content specific core options set to on

    (Well, I actually have all load options to on).

  • @pjft Thanks for the ideas. I checked all of those things, and the settings are like yours. I saved an opt file this time, and still the same issues. All my load options are on, but for some reason seems to be skipping loading the sh2 setting. I'm wondering, are you able to notice a difference between "fast" and "accurate"? I'm thinking that if you're overclocked, you may not be noticing the difference as much as myself.

    Thanks again, both of you. Will keep digging.

    Edit: I did notice, there's a ton of non-related data in the game-specific .opt file. Things related to other games and systems.

  • @jell Thanks. I don't think I'm overclocked in any way. I notice a difference between "slowdown" and "running well" - I can't directly attribute it to the fix or to the change in that setting, though, as I didn't explore it that much.

    When it was running slow, I noticed the sound being distorted and that's how I know it's not running at full speed.

    Hope you sort this out!

  • @pjft Okay, so I switched to the MAME 2003 roms. Gotta hit left, right at the beginning to get past the warning screen, but s1945ii, s1945iii, and soldivid seem to run normal speed from the start.

    I actually think the game was a little smoother with the FBA versions, and the graphics for soldivid seemed better in the FBA version, but not having to go to the RGUI menu each time is better from a UI point of view.

    Someday when FBA is updated again, I'll give it another go and see if things work out. Thanks again for your input and help!

  • @jell said in FBA: Some games requiring accessing RGUI menu to run full speed:

    Someday when FBA is updated again, I'll give it another go and see if things work out. Thanks again for your input and help!

    There is currently no issue with the code (tried it on several platforms). That's an issue with your setup. Don't expect a core update to solve it. As to why this setting is not saved/retrieved properly from your core option file, i can't be sure. Other options from this core and from other cores are saved/retrieved properly ?

  • @barbudreadmon Thanks so much for checking. Tested again to make sure the other game-specific core settings are saved/retrieved. Many of the options I have no way of telling, but the DAR/PAR aspect ratio is preserved between restarts when I create an .opt file for the game. Visually, I can tell as I switch back and forth.

    Perhaps there is another reason that's slowing the system down to levels similar to having the sh2 setting to "accurate", which is fixed when accessing the RGUI menu, and I've been following the wrong lead. One thing that makes me believe that it's related to the sh2 setting is that when I save the sh2 setting to "accurate" in the game-specific opt file, then I do a full reboot of the game and it starts out slow, then I fiddle in the menu (ultimately changing no settings), it is still slow. On the other hand, when I set the sh2 setting to "fast" and do the same thing, the game runs smooth smooth smooth, it's great!

    Thanks again for looking into this. If there's anything I can do to get more information as to what is happening under the hood, please let me know. One day I hope to brush the thick layer of dust off of my computer programming skills :)

    Edit: Updated retroarch and fba from source and tried again. Same result. May try on a fresh install someday, would be a good excuse to get a new (bigger) micro SD card!

  • I have this exact problem and it's really bothering me, because I love these games and they play noticably better in FBA than in MAME, but you need to enter the menu every time, or at least I do. Anyone found a fix? :/

  • @jell Did you ever figure out how to solve this? I have the exact same problem :/

  • @jenslyn87 in my case the options are saved and loaded as intended when I have it set to load per core and per game options, after saving the game options.

  • @pjft Thank you! I'll see if I can get this to work later today. The problem, as with the previous poster, is not that the setting isn't saved. The sh setting is saved as 'fast', but I have to actually fiddle around with it to get it working. So if I go from fast -> accurate -> fast it will work. However, anytime I end on 'accurate', it won't. This tells me that even though retropie tells me that the setting is set to 'fast', it doesn't loud as such. Sounds like exactly the problem the previous poster has.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.