Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Binding issues with SHERIFF



  • I can't find a way to get controls (bindings) work correctly in Sheriff under lr-mame2010 (Raspberry Pi3 with Retropie 4.3)

    alt text

    Sheriff is a really old arcade game (1979) that had very particular controls: a joystick for movement and a sort of "gas switch" for the shooting direction.

    alt text

    Using lr-mame2003 the controls work without requiring any special setting; movement is assigned to d-pad and shoot direction to right analog (xbox pc controller). The problem is with lr-mame2003 the game has no color and sound is totally messed up.

    In lr-mame2010 graphics and sound are ok but controls not working at all.
    Also in RGUI (1.6.7) under Quick menu there is no "controls" option (!). That option exists in lr-mame2003.

    Tried changing Mame bindings (thru "TAB" mame menu) and was able to assign keyboard arrows.
    In this way d-pad controls shoot direction. Unfortunately found no way to assign any buttons or joy for moving the character.

    Any ideas ?

    @caver01: as you're the controls & bindings master, any suggestion ?



  • @udb23 The 0.78 ROM works perfectly in 0.94 AdvanceMame. It has colour and sound. I haven't tried to map the controls but it should be easy to do in advanceMame using the TAB menu.



  • perhaps if you try to shoot the sheriff? I wouldnt shoot the deputy though.



  • @jonnykesh thank you. Will give it a try.
    Unfortunately advmame does not correctly supports overlays so I'd prefer a libretro core.



  • @udb23 I thought that might be the case.



  • @udb23 yeah I was going to suggest AdvMAME too.



  • After further testing these are the findings:

    • lr-mame2010 has no core remapping function (at least not for this rom).
      I created core remapping for the same rom in lr-mame2003 hoping lr-mame2010 would at least read that remap but it is simply ignoring it.

    • RGUI: input settings does not accept any keyboard key; only gamepad input. Not sure this is standard behaviour.

    • lr-mame2010: bindings thru TAB menu recognizes, on top of keyboard input, also gamepad dpad and buttons (no analog joysticks unfortunately). Was able to assign movement to the dpad, shoot direction to the A,B,X,Y buttons and actual shoot to the right trigger. Controls set this way work in the game (seems RGUI input configuration is ignored..).



  • btw: just noticed that RGUI is still the old "text one"; I remember seeing the new RGUI previously (graphical, same as windows retroarch) but cannot remember what core. Lr-mame2003 and 2010 now show the "old" one.
    Is RGUI version (new vs old) depending on the specific core ?



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.