Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

ssh connection problem



  • I have instaled retropie on my Raspbery pi 3n.
    I have a trouble with local lan connection via ssh with my Raspberry.

    • I have enabled the ssh service by raspi-config > interfacing options >> SSH >> Enable and I have rebooted my pi
    • I have connection with my pi via wifi (ping)
    • Unfortunatelly, I can't connect with my pi via putty or winscp,
      When I try to connect via putty my session is refused after typing the password:

    login as: pi
    pi@192.168.1.5's password:

    When I try the ssh session from my terminal on Retropie:
    ssh pi@localhost

    after typing password, the connection is established.

    I have another one problem. I have changed my pasword to pi user via passwd. Unfortunatelly, ssh can't see this and after ssh login in the terminal, still write formula "ssh is enabled and the default password for the 'pi' user has not been changed".

    I'm beginner on raspberry and I can't fix that
    Please help :)
    Tomasz


  • Global Moderator

    @tbartus Do you have any error messages in /var/log/auth.log when you're trying a remote login ? Did you do any other modifications on the system ?



  • @mitu
    System have not any modifications.

    My sessions:
    login as: pi
    pi@192.168.1.5's password:
    Access denied
    pi@192.168.1.5's password:
    Access denied
    pi@192.168.1.5's password:

    /var/log/auth.log:
    Jul 6 04:40:51 retropie sshd[11022]: Failed password for pi from 192.168.1.6 port 50599 ssh2
    Jul 6 04:42:22 retropie sshd[11022]: Failed password for pi from 192.168.1.6 port 50599 ssh2
    Jul 6 04:42:31 retropie sshd[11022]: Accepted password for pi from 192.168.1.6 port 50599 ssh2
    Jul 6 04:42:31 retropie sshd[11022]: pam_unix(sshd:session): session opened for user pi by (uid=0)

    surprising, because I have not a command prompt in my putty window.
    But what about the system date??? I have the Internet connection...
    Tomasz


  • Global Moderator

    @tbartus About the date - check the timezone on the system, could be there is a difference between your timezone and the one set on the Raspberry PI.
    Run sudo dpkg-reconfigure tzdata to set the timezone on the PI.



  • @mitu
    hmmm... I have changed time zone to Warsaw but still the time is wrong...

    Current default time zone" "Europe/Warsaw"
    Locale time is now: Mon Oct 23 21:34:31 CEST 2017
    Universal time is now: Mon Oct 23 19:34:31 CEST 2017

    But current real time is: 18:34


  • Global Moderator

    @tbartus Then it means you're not synchronized to a time server - check https://wiki.debian.org/NTP for troubleshooting info.
    You didn't give any specifics about your system - are you using the RetroPIe image or you install on-top of an existing Raspbian/Other distro ?



  • @mitu
    Sorry, my fault :)
    I have the system from the newest image of Retropie from the https://retropie.org.uk/download/



  • Maybe someone will use it:
    NTP (Network Time Protokol) in Raspbian
    https://webinsider.pl/raspberry-pi-ntp-network-time-protokol/


  • Global Moderator

    @tbartus NTP is already configured - and working - in the image that comes with RetroPie, I'm not sure why it's not working for you.



  • @mitu I have configured it again. Now service works correctly. Do you have any idea with ssh service? It looks like the service works OK, the server answers to remote login, but putty session after typing password, hangs out and doest'n apear the session prompt. SSH Putty sessions with the other remote computers works correctly.


  • Global Moderator

    @tbartus I have no idea why Putty is giving you troubles, but I don't think it's a problem on the RPI side. Try using another Putty version or enable the debug log for Putty and see why it gets stuck.

    Maybe you have a particular Putty configuration - if you're using it for more than the PI system, you might have configured some options which are not compatible with the ssh version from the Raspian system.



  • @tbartus Try using KiTTY



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.