Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • Pi Model : 3
    Power Supply used: Power supply 100-240V to 24V 4A (perfect for the DAC)
    RetroPie Version Used : 4.3
    Built From: Pre made SD Image on RetroPie website

    Hello everyone! I recently bought this DAC and it doesn't make any sound. All connections have been made. I followed these explanations (https://www.hifiberry.com/build/documentation/hifiberry-software-configuration/) to install the drivers which are the same as for Hifiberry of what I thought I understood. I don't know what to do to make it work.
    Thank you in advance.


  • @cubacraft You did see that at the top of that guide you linked that it is "an outdated guide." Might that have something to do with it? Have you contacted the folks who made the DAC? I am not sure we are going to be much help getting hifiberry working, but maybe they have a forum that can help.


  • Sorry, I followed these explanations (https://support.hifiberry.com/hc/en-us/articles/205377651-Configuring-Linux-4-x-or-higher). I had used the previous link but I realized my mistake and corrected it.
    I did "aplay -l" and the command returned "aplay: device_list:268: no soundcards found..." to me. It's not even detected.
    I tried to contact them but no response has been forthcoming for a few days.


  • @cubacraft I am not sure what to tell you. RetroPie did not make the DAC, so unless there is some support community around that hardware to help with your configuration, I don't think anyone here will have any better advice. MAYBE you will find someone here that also uses your DAC who can offer advice, but frankly, this is a forum of people configuring emulators, not DACs. You would have a better chance getting random help by posting this in a DAC forum.


  • Now I have sound but just with my python script allowing me to have music on the menu...

  • Global Moderator

    @cubacraft What does aplay -l list now ? Get the output and then play with the sound configuration in ES to match what the command says.


  • "aplay -l" return : "
    **** List of PLAYBACK Hardware Devices ****
    card 0: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 []
    Subdevices: 0/1
    Subdevice #0: subdevice #0
    "

    Before the sound configuration menu, the raspberry return me this:
    lv10: VolumeControl::init() - Failed to find mixer elements!
    lv10: AudioManager Error - Unable to open SDL audio: ALSA: Couldn't open audio device: Device or resource busy


  • And "this sound device does not have any control" in AlsaMixer.


  • I changed the name of the audio device in the file "es_settings.cfg" but nothing happen.

  • Global Moderator

    @cubacraft From what I can see on the HifiBerry forums one problem might be that the mixer control is not properly detected - or rather is not the analog, but digital - by the Alsa lib and consequently by the SDL library which is used ES and most of the emulators.
    You could try using the dmix Alsa mixer , explained in https://support.hifiberry.com/hc/en-us/articles/207397665-Mixing-different-audio-sources .

    The name of the audio device can be set from the ES interface, you don't need to fiddle with the config file directly.


  • This tutorial doesn't work for me. dmix didn't change anything. I've tried different things but it doesn't work. I have to admit I'm starting to despair. However, I'm sure there's a way that my python program sounds great. I continue to search and hopefully find a solution.


  • Can this be a permission problem? I have to be a super user to run the command line sound tests otherwise it doesn't work.


  • I wouldn't change anything directly on es_settings.cfg but rather through the sound settings menu. Change the device and then restart EmulationStation and see if it works.


  • The sound settings don't change anything and when I use raspi_config settings to force to Auto, jack or HDMI, the raspberry answers me: "There was an error running option A4 Audio".


  • I'm going to post here the result of a few lines of commands, hoping that it will help to understand...

    lsmod command return me this:
    Module Size Used by
    bnep 12051 2
    hci_uart 20020 1
    btbcm 7916 1 hci_uart
    bluetooth 365780 22 hci_uart,bnep,btbcm
    evdev 12423 2
    joydev 9988 0
    brcmfmac 292632 0
    brcmutil 9863 1 brcmfmac
    cfg80211 544609 1 brcmfmac
    rfkill 20851 4 bluetooth,cfg80211
    xpad 16908 0
    ff_memless 5315 1 xpad
    snd_soc_hifiberry_dac 3230 2
    snd_soc_bcm2835_i2s 7480 2
    bcm2835_gpiomem 3940 0
    snd_soc_pcm5102a 2310 1
    snd_soc_core 180471 3 snd_soc_bcm2835_i2s,snd_soc_hifiberry_dac,snd_soc_pcm5102a
    snd_compress 10384 1 snd_soc_core
    snd_pcm_dmaengine 5894 1 snd_soc_core
    snd_pcm 98501 5 snd_pcm_dmaengine,snd_soc_bcm2835_i2s,snd_soc_core,snd_soc_hifib erry_dac
    snd_timer 23968 2 snd_pcm
    snd 70032 6 snd_compress,snd_timer,snd_soc_core,snd_pcm
    uio_pdrv_genirq 3923 0
    fixed 3285 0
    uio 10204 1 uio_pdrv_genirq
    uinput 9125 0
    fuse 99603 1
    ipv6 408900 34

    amixer cset numid=3 0 return me amixer: Cannot find the given element from control default

    cat /proc/asound/cards return me :
    0 [sndrpihifiberry]: HifiberryDac - snd_rpi_hifiberry_dac
    snd_rpi_hifiberry_dac

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.