Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Trying to add a new system - stuck already with the system.svg...



  • Hi guys,

    I am trying to expand my Retropie setup with a dedicated ZX-81 emulator (Zesarux) besides my existing ZX-Spectrum system (LR-Fuse). I have read all the instructions but when I try to create a system image it does show up in ES but the colors do not show. It's in the right place, shows up when it needs to but only black and white.![0_1511427593738_not-working-system.svg](Uploading 100%)

    I have taken a crash course into SVG editing with Inkscape but I do not seem to do things right. I just copied the existing zxspectrum.svg. Transparency works but I can't seem to get it working. It has taken me about 4 hours to get here but not giving up.

    Can anyone tell me what is wrong with this picture?

    https://www.dropbox.com/s/ptq8ahqhilfzxhg/not-working-system.svg?dl=0

    Thanks,

    Theo.
    [0_1511427674859_not-working-system.zip](Uploading 100%)



  • @tredelijkheid What theme are you using?



  • Apologies.. it's Carbon.



  • @tredelijkheid And the system logo is appearing in B&W?
    EDIT: Just tried it. Same for me. I'm no expert on svg images but I know that the RP version of ES does not support any transparancies or gradients in .svgs. Perhaps this logo is transparent? I dunno. Maybe just use a .png?



  • @tredelijkheid To use svgs in ES, "strokes" and text must be transformed to "path" using the Trace Bitmap feature in Inkscape. Here is a video tutorial outlining the process. This is the tutorial I have used to successfully create logos for ES.

    For ZX81, you can find svgs at the Recalbox Theme repo.



  • @jonnykesh Transparancies work OK, also with the existing system.svg's. PNG is no option, they are bitmaps and can't scale.
    Thanks for trying to help me out...



  • @dudleydes Hi,

    I indeed used this great tutorial and converted the bitmap to the vectored image. I followed every step in the tutorial and tried to replicate the same process in Adobe illustrator. At the end all of the vector imaging tools show the logo perfectly but ES does not...

    The SVG files are just text and if I edit them with a text editor it looks fairly good as my debugging goes.

    I have quite some Linux knowledge, use Photoshop daily, am familiar with hardware and programming but this vectored image stuff is quite a science on it's own...

    Thanks for pointing me to the Recalbox. Great examples.

    Because I have invested so much time and effort to get it right I am hoping that someone could look at the file and tell me what is wrong. Again, it looks quite OK but in ES it does not. For now I can use the Recalbox images but still want to know what is wrong with mine.

    Theo.



  • @tredelijkheid said in Trying to add a new system - stuck already with the system.svg...:

    someone could look at the file and tell me what is wrong. Again, it looks quite OK but in ES it does not.

    I quickly checked the file and it seems ok, as you said.
    I noticed the image "size" (dimension of the page in inkscape) is quite big compared to usual system svgs. ES does scale it but sometimes that scaling has issues.
    I would suggest you open one of the existing ES system.svgs (or any of my custom system icons) , save it with a different name, delete all objects (making it "empty"), open your sinclair svg, select all objects and paste them in the "empy" svg, group all objects and save.
    That should fix your problem.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.