Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Getting Brutal Doom To Run WELL?



  • @edmaul69
    i just get a launch command screen that wont take controller input it asks me to select a default emulator options
    1 wich is blank and does nothing
    2 wich is brutalzdoom then i get a black screen as if zdoom was going to start but after 5/10 seconds back to emulationstation im sorry to be a pain but im a huge doom fan and this would mean a lot to me.

    so my Doom - Brutal Doom.sh
    is at

    /home/pi/RetroPie/roms/doom/Doom/Mods/Doom - Brutal Doom.sh

    and looks like

    #!/bin/bash
    "/opt/retropie/supplementary/runcommand/runcommand.sh" 0 PORT brutalzdoom

    i copied your emulators.cfg to /opt/retropie/configs/ports/brutalzdoom

    so it now looks like this (the adresses of doom and the .pk3 are correct)

    brutalzdoom = "/opt/retropie/ports/zdoom/zdoom -iwad /home/pi/RetroPie/roms/doom/Doom/doom.wad -file /home/pi/RetroPie/roms/doom/Doom/Mods/brutalv20b.pk3"

    brutalzdoom = "/opt/retropie/ports/zdoom/zdoom -iwad /home/pi/RetroPie/roms/doom/Doom/doom.wad -file /home/pi/RetroPie/roms/doom/Doom/Mods/brutalv20b.pk3"

    if you can see whare ive gone wrong id be super greatfull dude :)


  • Banned

    Can lr-pboom handle this?


  • Global Moderator

    @darishzone

    ZDoom is required to play 'Brutal Doom' on RetroPie.


  • Banned

    Ok, thank you!



  • @8bitkid why is your wads in /roms/doom/Doom/? Do you not keep them in /roms/ports/doom/? Also when you changed the emulators.cfg you needed to also add the line

    default = “brutalzdoom”


  • thanks ill go try edit the cfg again and post my results, i don't keep them in ports doom although i have tried that (with the corresponding changes to cfg and .sh) in the hopes that BD would work that way but it didn't make any difference.

    i have them separate as i have doom as its own system in es with the doom logo for art.
    i use it to collect all my classic fps games via shortcut so duked 3d hexen etc as well as a bunch of dos based fps like blood, shadow warrior, blake stone, etc.
    i just really love those games and i didn't like having them all mixed into ports with zelda clones/ commander keen and whatever else is in ports or dos. so i created a carbon edit with an extra system.



  • i tested it to no avail im currently unable to clone my build so i bough a new sd card from amazon il try burning a fresh one man i really want this to work :)



  • @8bitkid you arent trying to do this with the shareware doom wad that came with the emulators are you? If so you need the real doom wad. Not sure why it isn’t working for you.



  • im also really confused its the doom.wad from my ultimate doom cd (same with all 4 wads) the only thing i can think is i recompiled zdooms menu following a guide and perhaps the guide used an older build or something idk i got a brand new sd today so its fresh download/ install retropie 4.4 then il install zdoom first before anything else and il use doom from ports and exact copies of your cfg and .sh if that doesn't work idk



  • @8bitkid you cant use the doom shareware wad that comes with the emulators. You need to overwrite it with your ultimate doom wad


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.