Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Raspberry PI 3 Ethernet problem



  • Hello,

    I have a problem with my Retropie/Raspberry. I flashed the SD card with the latest version.
    Only i can not get the ethernet to work,

    It gives me a ipadress of 169.254.9.111, so it can not find my DHCP server i think.
    I tried giving it a static IP adres

    i changed /etc/network/interfaces to iface eth0 inet static.

    and added the following to /etc/dhcpcd.conf

    interface eth0
    static ip_address=192.168.1.128/150
    static routers=192.168.1.1
    static domain_name_servers=192.168.1.1

    but it does not change anything. Does anyone have any idea ?



  • @nextria 192.168.1.128/150 is not a valid IP. I am assuming standard private IP addressing and your subnet is probably going to be 255.255.255.0 so your IP should be 192.168.1.128/24

    As to why it's not giving you a DHCP, I have no idea. Have you tried another cable and port on your router?



  • @markyh444 hey, i tried that ipadres too, but it does not work either.

    I redownloaded the img, and flashed it to the sdcard but no luck.
    Also tried other cable and port, could it be my pi's ethernet is broken ?



  • @nextria maybe, have you tried configuring the WiFi? Do your other devices connect to the router fine and get assigned a DHCP address?



  • @markyh444 yes wifi works without any problem I also tried it now with rabian lite and is also not working.



  • @nextria I'd say dodgy LAN port or cable then.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.