Please do not post a support request without first reading and following the advice in

Favorites menu disappeared

  • I set up a new RetroPie 4.3 installation on a Raspberry Pi 3 model B (using the pre-built image from the web site), copied a bunch of games across to it and everything seemed to be working fine, including the favorites menu - I tagged a few SNES and Mega Drive games as favorites and the option appeared on the main menu and listed them okay.

    I then decided (perhaps foolishly) to swap some of the ROM sets for renamed ones, so I deleted the old ROM files and copied across new ones. RetroPie has picked this up, and everything seems to be working fine except for the main menu favorites collection - even though I've got it turned on in the menus it doesn't show up any more.

    I'm surmising (although I have no proof) that this is somehow due to it remembering the old filenames from the deleted ROM sets. The 'last played' menu does work properly, however - the deleted files just don't appear in that list any more.

    Does anyone have any ideas how I can troubleshoot this and/or kick it back into life? Adding new favorites works and I can filter within each system list, it's just the icon on the main menu that won't show up.


  • Global Moderator

    @blerkotron Update to the latest version of RetroPie and update all your packages, some time ago there was a bug in Emulationstation w.r.t. Favorites.
    Note that you need to exit Emulationstation 'cleanly' - from its menu - and not just cut the power to the PI system in order for Emulationstation to save the Favorites between restarts.

  • Thanks for the reply. I did a full update of everything (which took quite a while) but it doesn't seem to have helped - the 'all' and 'last played' collections are working okay, but 'favorites' still won't show up.

    Favorites do seem to be saving properly, as I said before - I can go to (say) the SNES list and filter to just favorites okay on there, it's just the entry on the main menu carousel that won't appear any more.

  • Global Moderator

    @blerkotron Are you sure you have enabled it ? Try disable it, restart ES, then enable it again (in the Custom Collections menu).

  • That worked! Turned it off in the menu, rebooted, turned it on again - menu appears! Weird, but thanks so much for the suggestion - that's been annoying me for days!

  • I've encountered this too. Usually just disabling, hitting B (back to apply), and then re-enabling brings it up fine.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.