Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Emulation Station screen no longer fits on TV properly



  • Was playing with the overscan enable disable In raspi-config to get rid of some the black bars in screens whilst this as helped I now have an issue where the bottom on the main emulation station interface where it shows the button for screen saver select system etc are slightly off the screen. Disabling and re-enabling overscan makes no difference nor does adjusting the left right up down overscan settings. It is also slightly off to the left.

    Any suggestions how to fix this without reloading the Pi from scratch?

    Thanks,
    Dwarfboysim



  • Same situation here with my Pi which is connected to the CRT.
    Worked fine till the last updates, now i also have the screen expanded in Emulationstation, i also can see "reensaver" from "launch screensaver" i.e.
    And of course you have to guess the names in the gamelist šŸ˜Š.

    I also tried to play with the overscan entry in the config.txt.
    Furthermore i tried changing the sdtv-mode, sdtv-mode_aspect, set the framebuffer to 800x600 and the left and right overscan values to +70.

    The funny thing is: it works!
    It works great! But only in the terminal!
    The boot up sequence runs great, i can see all the four raspberrys and read the whole text, nothing is missing on the left side of the screen.

    Until....the splashscreen and emulationstation is loading!
    It seems that ES says "...so you set your own screensize? Know what? I dont give a shit about it!"
    šŸ˜Š

    I did not have this earlier.
    I connected my Pi to the CRT with a 3,5mm Jack, disabled overscan, set sdtv_mode to 2 for PAL and it worked like a charm.

    On my other Pi, which is connected to a 55" Bravia via HDMI, i do not have this problem.

    Looks like the newest releases seem to have problems with Emulationstation in 4:3 Format.
    Not Raspbian or the Pi itself have these issues, its just affecting Emulationstation.



  • @dwarfboysim @sirhenrythe5th If the overscan settings works on the terminal but not on ES try setting overscan_scale=1 in the config file, for me that worked to make so that the overscan changes applied to everything not just the terminal.

    https://elinux.org/R-Pi_Troubleshooting#Big_black_borders_around_small_image_on_HD_monitors



  • @isrnick THANK YOU SO MUCH!!!
    One short answer did solve my problem!
    Did not know that scale-command, never heard of it before.
    Great help - thx Dude!!!



  • Hi all,
    So just to clarify you are saying its possible to:

    1. Disable the overscan via raspi-config to get rid of the black border
    2. Enable the overscan_scale=1 in config.txt

    I did these steps but ES still had its own ideas. Could I use the manual settings in config.txt for the left, right, up, down etc values to re-centre it. I also noticed that with overscan disabled my MAME games get cut off at the top a bit as well.

    Is there a preferred option I should be setting the display settings to in the rasp-config. I have a 55"4k Display.

    Thanks,
    Dwarfboysim



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.