Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

How Interface to Pi to add and remove files with Mac Easily



  • I have the basics of the Terminal on the Mac down to access the pi. I even have some program called I think Filezilla to add programs to the pi and have a GUI. However, Filezilla doesn't erase files, at least not well.

    My issue is when I connect the pi to the network via wifi (my mac doesn't have Ethernet), the pi doesn't always show as a device on my mac. Additionally, when it does, it often doesn't connect and allow me access in the finder to files on the Pi. This leaves me filezilla only.

    Is there something I need to setup to make sure I can access the device on my mac? Any thoughts?


  • Global Moderator

    @jimd0586

    Cyberduck seems to be the biggest crowd pleaser for Mac users. You can connect to the pi using SFTP or FTP. When asked to authenticate, the username is "pi" and the password is "raspberry".



  • @mediamogul

    I'll give it a shot. Thank you!



  • @jimd0586
    Honestly, I don't bother with FTP on the Mac. If your PI is on your network, which it would be if you are trying to use FTP, just open up a finder window, go to Shared, All and find RetroPie. Open it and you should see shares where you can connect to to BIOS, configs, roms and splashscreens. Moving files to and from the Mac isn't much easier than this, and you can directly edit retroarch configs and so on.

    I wonder if perhaps it's time to reboot a router? What version of Mac OS are you running? It may have to do with SAMBA bugs which I know have come and gone over the years in Mac OS.



  • @caver01

    That's just it though, I see Retropie there but it won't connect. I have to use Filezilla or some other App.



  • @jimd0586 It might be a residual name in the network list. I have seen old system names cached that way. They appear in the finder list, but it's a ghost, possibly with the wrong IP being remembered. Have you tried opening a network location: Go menu, Connect to Server. . . Then enter the address smb://IP-address-of-pi?


  • Global Moderator

    @caver01

    He's right, there's currently an issue with SMB in regard to Mac systems that was introduced in a binary update a few weeks ago. It is possible to connect in the way that you suggest, but it requires adding the user "pi" to the SMB user list. After that, you could log in after giving the proper credentials. Seeing as how SMB has been on the bubble of uselessness in OSX ever since Apple decided to rewrite their own implementation in 10.7 (Lion), FTP and SFTP have become the path of least resistance for most users looking to connect to Linux systems.

    Edit: The issue, as well as the workaround, is documented below:
    https://retropie.org.uk/forum/topic/754/samba-under-mac-3-7-stopped-working



  • I would recommend using 'Transmit':

    https://panic.com/transmit/


  • Global Moderator

    @Wolfman100

    'Transmit' is easily the best application of it's kind for the Mac by a good margin. However, second best starts looking a whole lot more attractive after you consider the price they're asking for what's still only a file transfer app.



  • Thanks guys!



  • I was having good luck using the program Fetch to SFTP from my Mac to my Pi.
    I reimaged my Pi and now I can't get it to connect again.
    Getting an error as though I'm using the wrong host name, username, password, and authentication method...

    any ideas?


  • Global Moderator

    @fafner

    You might try backing up and then deleting ~/.ssh/known_hosts from your mac.



  • @mediamogul said in How Interface to Pi to add and remove files with Mac Easily:

    ~/.ssh/known_hosts

    I am forever in your debt!!

    Thanks!



  • @mediamogul said in How Interface to Pi to add and remove files with Mac Easily:

    @fafner

    You might try backing up and then deleting ~/.ssh/known_hosts from your mac.

    Thank you!

    This fixed my issue where I wanted to start fresh with the RetroPie image, and couldn't connect with my FTP client (Transmit) via WiFi. As a note, I also reserved an ip for my RetroPie on my router using it's MAC address, found by an ip scanner.

    I'm not an experienced terminal user, but this is what worked for me, I hope this helps someone that needs it:

    1. open Terminal
    2. cp ~/.ssh/known_hosts ~/.ssh/known_hosts.bak
    3. rm ~/.ssh/known_hosts
    4. exit
    5. reboot mac (not sure if it's necessary, but can't hurt!)
    6. connect via ip address in ftp client


  • Hi folks, going to bring this topic back to help me solve a problem...

    I'm getting back into using my Pi after a while, and although on my Mac I can access it no problem with Transmit or CyberDuck, I'm getting a Permission Denied error when I try (in my example) to upload a modified config.txt file.

    What have I forgotten here? I know I've done this in the past. I did the Terminal operation above, but connecting is not my issue, just permission...

    I can create a bookmark with the IP address and user "pi" in CyberDuck for example, but notice there's no place to enter my password. I assume that's what's blocking me from writing?



  • I see this thread "SSH doesn't allow me to modify file"... https://www.raspberrypi.org/forums/viewtopic.php?f=63&t=62443

    ...and now I wonder how I ever did this in the first place :)

    I can certainly go back to making a few changes to config.txt on the Pi itself, but I thought I had figured out a way such as this to store a couple of versions of that config file (eg. one for a CRT and one for HDTV), and just swap them in and out like this without the typing.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.