Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

How to start a binary with EmulationStation



  • I need some help with starting some games I added to my ports folder.

    I managed to build a version of this on Raspbian that runs well in fullscreen compared to the build in fullscreen option of the game. I used a SDL 2 without X version to build it.

    Now I'm trying to run it with RetroPie, but I can't figure out how. I can't execute it from the comandline due to some restrictions, I tried modifying a script from zerojays repo.

    #!/bin/bash
    "/opt/retropie/supplementary/runcommand/runcommand.sh" 0 _PORT_ derclou "/home/pi/RetroPie/roms/ports/DerClou/derclou"
    

    But I get a No Config found error with that. I also tried to run a Port of CSBwin with that method before and thought that the no config error was a message from CSBwin.

    So I need a way to launch a binary within its folder (because it also contains the game files) and is capable to add parameters (I need that for CSBwin to tell the game which dungeon to use).

    Any help would be appreciated.



  • @ectoone in /opt/retropie/configs/ports/ you need a folder called derclou. Then in that folder you need a file called emulators.cfg . Feel free to look at other ports games emulators.cfg to know how to setup the emulators.cfg you need.



  • Ok i got Der Clou running, although I have to say that this is overly complicated and I need the whole game folder on the SD card because if i try to keep it on my USB stick I get a no permission error.

    I'm also struggling with parameters for CSBwin. This is my emulator.cfg with some global parameters:

    CSBwin = "/opt/retropie/ports/csbwin/CSBwin --fullscreen --extralarge --norecord"
    default = "CSBwin"
    

    And this is the .sh to start one of the dungeons:

    #!/bin/bash
    "/opt/retropie/supplementary/runcommand/runcommand.sh" 0 _PORT_ csbwin "--directory /home/pi/RetroPie/roms/ports-data/CSBwin/dm"
    

    But specifying the path with that method seems not to work.
    I also tried to put the whole parameters in the emulator.cfg and changed the paths accordingly:

    CSBwin-DM = "/opt/retropie/ports/csbwin/CSBwin --directory /home/pi/RetroPie/roms/ports-data/CSBwin/dm --gamsav /home/pi/RetroPie/roms/ports-data/CSBwin/dm --root-path /opt/retropie/ports/csbwin --fullscreen --extralarge --norecord"
    CSBwin-CSB = "/opt/retropie/ports/csbwin/CSBwin --directory /home/pi/RetroPie/roms/ports-data/CSBwin/csb --gamsav /home/pi/RetroPie/roms/ports-data/CSBwin/csb --root-path /opt/retropie/ports/csbwin --fullscreen --extralarge --norecord"
    CSBwin-CONFLUX = "/opt/retropie/ports/csbwin/CSBwin --directory /home/pi/RetroPie/roms/ports-data/CSBwin/conflux --gamsav /home/pi/RetroPie/roms/ports-data/CSBwin/conflux --root-path /opt/retropie/ports/csbwin --fullscreen --extralarge --norecord"
    default = "CSBwin-DM"
    

    But I can't set which default version to use per .sh (rom). It always uses the last selected path.



  • Ok, so I've created separate emulator.cfg for each version of CSBwin I'm using and that works fine.

    But now I have troubles with Der Clou again. After a reboot I can't start it from ES anymore, I get:

    Executing: /opt/retropie/ports/theclue/theclue
    ERROR: Module Dsk: Open :./pictures/bubble.fnt
    

    And it seems to be a path issues, because I get the same error when I try to run the binary from the menu in Raspbian.
    I can run it when I go to the directory manually at the command promt. So my guess is that the script not goes into the directory and thats why it can't find the datafiles anymore. Weird thing is, that I can run it from ES after I started it once from the command promt.

    Also i just noticed that I can't save because of restrictions. D:



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.