Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Help with PS3 controller over Bluetooth



  • Hey everybody, I searched and read through first 5 pages of posts but did not come up with any answers to the specific issue. I'll try to word this as accurately as possible, English isn't my native language.

    Using REtropie 4.3, all driver packages up to date far as I know.
    No outboard dongles or bluetooth peripherals connected
    Have access to Bluetooth Keyboard? Yes

    I have attempted to pair the PS3 controller through Retroarch AND through Retropie 'auto setup' where it walk you through the process. Everything functions OK in ES, but as soon as a ROM is instantiated, the function of the controller is not there. No buttons work. As far as I can tell, everything set up OK from everything I've Googled about this.

    I found one thread which instructed me to manually go in to the terminal and download the PS3 drivers (already installed in my circumstance) and I tried that. I couldn't actually download the file at one point because the file has moved since the creation of that thread back in 2015 or something, so no go there. I've been in a little bit of a loop for this issue, if anyone can assist that would be good.

    Tangent: Another issue I have with my Buffalo SNES controller is that on some games (Chrono Trigger is a bad one with it's 'accept' button) a few buttons are extremely sensitive and will initiate multiple activations upon one press. Is there way to alleviate that, to 'dumb down' the sensativity on certain games?
    Thanks!



  • @darklordenron Someone else will hopefully help out with the Bluetooth issue, I don't use it. Wired controllers only.
    As for the iBuffalo it sounds like you have the TURBO function enabled. Hold down the button causing the issue and press the CLEAR button.



  • Thanks for the reply, that resolved that problem with the turbo! :)

    Interestingly, the same first issue occurs with my wired Xbox360 to USB controller when I attempted to use that one as well..shrug



  • @darklordenron said in Help with PS3 controller over Bluetooth:

    Interestingly, the same first issue occurs with my wired Xbox360 to USB controller when I attempted to use that one as well..shrug

    @darklordenron did you try a USB cable for the PS3 controller, to check if you get the same problem when not connecting through Bluetooth?

    If my Pi arrives in time, I'm going to set everything up this weekend and I wanted to use a PS3 controller as well so naturally I'm going to keep an eye on if anyone gives you a good way to fix the issue.



  • @billyh Thanks, yes, same issue if connected with cable unfortunately. When I connect it with the PS button, the controller vibrates a bunch, then LEDs stay solid and becomes connected properly. The controller claims to be configured when booting a game as seen in yellow text on the bottom left corner of the screen, but nothing seems to work while in game. Bizarre.



  • Bump, still having issue. Will try solution to manually setting input, found here:
    https://retropie.org.uk/docs/PS3-Controller/



  • @darklordenron I hadn't realised the way of connecting the controllers you mentioned in the OP was different from that doc, which is the one I found and wanted to use as well. My Pi should arrive today, I'll see how it works for me and post here if you keep having the problem.



  • @billyh It shouldn't be different. It seems completely straightforward. The only thing I haven't done is manually set up the controller input as seen about halfway through that doc, so I'm going to attempt that to see if that resolves it. I shouldn't really have to according to my research.

    Short of those document steps though, I'm at a loss. Everything points to 'it should just work once you do these steps' and mine simply...doesn't for some reason.

    Definitely keep me abreast, it would be interesting to see your experience with the exact same thing.



  • I would have reported back sooner but I've been busy googling why I cannot type a forward slash in the terminal. For some reason all I get is "#". No modifier keys such as ALT will allow the forward slash to be typed so I couldn't get this command off the ground: cd /opt/retropie/configs/all/retroarch-joypads/
    touch PLAYSTATION(R)3\ Controller.cfg
    nano PLAYSTATION(R)3\ Controller.cfg

    It's one thing after another here with this damn Playstation controller, I'm about to throw in the towel.



  • @darklordenron You need to set your locale and keyboard layout. The default is en-GB. You may well be somewhere else in the world with a different kb layout.
    Change these settings using sudo raspi-config



  • @jonnykesh Cool, thanks for that. I've found that "ALT + -" is my forward (backward?) space, but I'll attempt that config to set my region correctly.
    Tried the command to config the joypad for the PS3 but that command didnt' work, giving me an error stating that the directory could not be found.. This is getting sort of old, contemplating just wiping the damn thing and starting fresh at this point..



  • @darklordenron said in Help with PS3 controller over Bluetooth:

    Definitely keep me abreast, it would be interesting to see your experience with the exact same thing.

    Sorry, didn't use the PS3 controller in the end. I chickened out like the little bitch that I am, and immediately went for a wired controller instead. Specifically, a wired controller for the Switch, an official Nintendo one - the red one with all the power-ups on it, felt like it was made for RetroPie.



  • Ah, damn... I ended up nuking the Pi and started over with a fresh image TWICE and still experience the same issue with both PS3 controllers.. Sucks but I think I'm going to have to bite the bullet and buy some USB wired ones instead. I was trying to avoid all that as I already have controllers that SHOULD be working. Is there a way to test the bluetooth to ensure that my Pi's hardware is at least not the culprit in this equation?


  • Global Moderator

    @darklordenron You might try the new PS3 driver if you have the sixaxis controllers - https://retropie.org.uk/forum/topic/15967/sony-dualshock-3-call-for-testers-sixaxis-script-module - before re-installing or getting an USB cable.
    As for how to check if the bluetooth is working, you can pair the controllers from the Bluetooth devices dialog (https://retropie.org.uk/docs/8Bitdo-Controller/). I know the page is for another controller type, but the process is the same. If the pairing wors, then BT is functional.



  • UPDATE: RESOLVED

    I asked over on Reddit and got a response from a gent who really helped out with this suggestion:
    "RetroPie" >
    "RetroPie Setup" >
    "Configuration / Tools" >
    "805: configedit" >
    "Configure basic libretro emulator options" > At this point, you can either:
    "Configure default options for all libretro emulators" OR
    "Configure configure additional options for [EMULATOR NAME HERE]" In both cases ... go to
    "Choose joypad order" and set which ever connected gamepads as player 1-4

    I assigned defaults to all systems, then went in and specifically assigned the PS controller to PSX as 1 through 4. Restarted. Loaded up Tony Hawk 2 and presto, everything works perfectly (with the exception of wonky button maps but that's easily resolved) Thanks everyone for your input, I think* I have it all figured out now :) Hopefully if someone has this issue in the future they can dig up this thread and the solution.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.