Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Lightning bolt recently appeared (apple 10w usb power supply)...i know, I KNOW, but I wanted to double check before $$



  • So I recently purchased a Raspberry 3 and installed Retropie. I got it set up and installed maybe 200 roms across 3 emulators (SNES, NES, Genesis). I installed the img to a Samsung EVO sdxc and was powering it with a 5V/3A Motorola Turbopower 15 wall charger (model SPN5970A, i know it's OEM since it came with my phone). USB cable was an old leftover Nook charger cable.

    Hadn't had any problems until the other day i noticed that the lightning bolt was coming on regularly and staying on pretty much constantly. I had noticed the lightning bolt a few times before, but it would only come on for a second or two and then go away. I have a couple of hypotheses/questions in related to this situation.

    Initial hypothesis...the first thing i thought of was the most recent change i had done to the software. I was getting tired of the cord dangling for the Dualshock4 while playing, so i followed the instructions on the github site to get it working wirelessly. I had to use ds4drv since the script method didn't work. i also had to delete the "--hidraw" option for it to work. Since this was the only difference i could think, i wondered if i was somehow sucking too much power by enabling the onboard bluetooth and connecting (not incidentally, the Pi always told me i had low connectivity, polling around 18 responses/sec with the DS4). So i removed the offending line from /etc/local.rc ... rebooted, still had the problem when using the DS4 wired again.

    next theory went to google, clicked some threads on here and at reddit...consensus was clear...everyone says that power issues first thing to do is look at your supply/wire. so i did that. sure enough, i spied some missing insulation near the "micro" end of my usb cable. darn that ole nook. figured that exposed wire must be the cause of my undervoltage problems. swapped it out for a new cable....rebooted, still getting too much

    ...sigh

    now i'm getting annoyed start digging around for different usb power supplies to see if i can get lucky (i usually don't). i end up finding an extra Apple iPad charger that I forgot I had. It says it's 5.1v/2.1 amp...I even check online and ensure that it's a genuine Apple power supply. I plugged it in with a smug amount of confidence since I had just read online a guy say that, like many apple products, they are overengineered to be like a tank. plug it in. you know what happened by now....lightning bolt....@#$% (i may have said a bad word in front of my 3 year old, who by now is saying "i thought you could fix it daddy" which is killing my ego, but he's just getting impatient to get back to playing Kirby

    actually, i'm just getting worried now have i somehow damaged my Pi by...

    • overpowering it with the 3amp motorola supply (though this guy seems to suggest no)
    • letting my son play and sometimes pulling to Pi down over the ledge of the tv stand a little a bit (though it never dropped and at most hung somewhat suspended applying downward force to the microusb input for a few seconds while i sat up to replace it)
    • running it at low voltage for too long...since i was continuing to play it and test it with different combos of adapters/cords to see if i could get a fix (my buddy with a PhD in physics said "eh, probably not" but wtf does HE know)

    now i KNOOOOOOW what you're gonna say "OP is dumb, he needs to buy an official raspberry pi power supply" .... "OP has too much time on his hands and should nut up and buy an appropriate charger, they're only 8ish dollars (which actually increases the price of the Pi by 20%...but whos counting)" ... OP did you even READ the documentation or forums?

    I promise I did. i am just wondering if anyone might have any insight into my situation. most specifically

    1. did i unwittingly but perhaps stupidly fubar my pi? either by running it OVER powered or UNDERpowered
    2. is it possible that since i bought from the pi from a reseller (albeit an authorized one) that i got a less-than-ideal board?

    some vaguely interesting details

    • the problem is mosty the symbol, but when playing some SNES games, i have experienced slowdowns
    • in trying a different combination of cords/adapters, i did find ONE combination that gave me decent results. it was the Apple 10w charger with a particularly snug fitting cable that i rarely use . i did still get the lightning bolt, but not as consistently. i even fiddled around with the "lay" of the cord, to see if that helped. maybe it did, maybe it was all in my head.

    details requested on "read here first" sticky...
    Pi Model or other hardware: Raspberry Pi 3
    Power Supply used: Apple 10w 5.1v 2.1a usb power supply (the middle one listed here)
    RetroPie Version Used : 4.3
    Built From: SD img downloaded from retropie website (downloaded on 2/14/18...filename is retropie-4.3-rpi2_rpi3.img)
    USB Devices connected: one wireless adapter for Lenovo N5902, Sony Dualshock4 (but not always both)
    Controller used: Sony Dualshock4
    Error messages received: yellow lightning bolt
    Emulator: (Name of emulator - if applicable) all, but default SNES core presents most problem



  • @creativename Phone/tablet chargers are not good for the pi. They are meant to charge devices not power them. SO don't expect a constant output of power from them. Take the advice many have suggested..get an official pi 2.5a ac adapter. 2.5a is the maximum the pi will take so using a 3a won't do anything but maybe compensate for the lack of constant power output. It won't kill the pi. Others have used the canakit one or other brands but my lightning bolt problems went away when I bought the official. You can also try a thicker gauge microusb cable but I bet you won't need one when you stop using phone/tablet chargers..



  • The problem is the gauge in of most USB charging cables. They are too thin and can't push the full current of the charger and hold a decent 5V over 5-6ft distance. Those cables are designed for charging a battery and not powering a device. Loss can work fine for charging. If you actually get an official power supply or one thats designed for the pi, you will see that the cables are much thicker. The pi needs its voltage to remain over 5V.


  • Global Moderator

    I would imagine that the DS4 would draw more power from the USB port as opposed to the lesser power draw from Bluetooth communication.

    You're most likely seeing one or both of the following issues:

    1. Your USB cable's internal resistance is too high, so not enough current is being supplied.
    2. Many 5v/2-3A chargers don't actually provide a reliable 5v at the same time that the maximum rated amperage is being drawn.

    The best course of action is to buy the official power supply, but failing that, try a better quality USB cable. I honestly doubt that your Pi got damaged.


  • administrators

    @psyke83 can confirm in my case that a crappy usb cable can ruin the best of power supplies.



  • welp gentlemen, the power supply came in and boy did it come through. son and I have been blazing through kirby and castlevania like no body's bizness. thanks for all the advice and info, twas heplful.

    for future searchers...I went with this Canakit model that had good reviews

    Now it's on to more discrete problems!



  • I have that same power supply, it has worked solidly for me for over a year.



  • @creativename be careful when buying those apple chargers. There is actually a 12v apple charger that looks the same.



  • @creativename i only use the canakits except in my pistation build which need to run a hub and a hdd off of the same power supply and the canakit isnt enough. I use two canakits on my apple iie pi.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.