Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Single .pbp being ignored.



  • Raspberry pi 3 running Retropie 4.3.12 from Retropie website.

    Having a problem with Final Fantasy 8.pbp. It started as a metadata issue, noticed that no matter what I did, this game just would not be scraped and save. I tried the built in scraper, Selph's scraper, and Ultimate XML scraper. I even tried just editing the the gamelist.xml myself and nothing sticks. This is all done with ES shutdown and checked after trying both a restart of ES and a reboot of the whole system. Then, I found this in es_log.txt,

    lvl1: File "/home/pi/RetroPie/roms/psx/Final Fantasy 8.PBP" does not exist! Ignoring.

    I've double and triple checked that the file is there and that the spelling, spacing, syntax of the .xml, and capitalization are the same and correct. I've tried renaming the rom file and the path in the .xml to see if maybe something with the name was causing the issue and as of last night, created a brand new .pbp from the .bin files myself. It's still being ignored. I've got nothing, can anyone help?



  • @solidgear4 What happens if you remove the game entry in the gamelist file and restart ES ? Is it detected ? Please give more info about your system as specified in https://retropie.org.uk/forum/topic/3/read-this-first



  • @mitu Yes I've tried that already, it still does not detect it.

    SN30 Pro controller, using lr-pcsx-rearmed, file is in /home/pi/RetroPie/roms/psx/Final Fantasy 8.PBP

    Sorry, if you need something more specific, I'll gladly provide it, I'm just still kinda new to all of this so I'm not really sure what else you need.

    Edit: Sorry, I should specify, the game itself is detected in that it is playable. It's just no metadata will attach to it.



  • @solidgear4 Can you check the permissions on the file ? Is it readable by the pi user ?



  • @mitu It is, it has the same permissions as every other .pbp



  • That's strange. I did a quick test - created a (quasi)empty file (Final Fantasy 8.PBP) in the psx rom folder, restarted ES and it's picked up, scraping works also

    0_1520976440434_snapshot.jpg

    Leaving aside any filesystem problems - any errors reported by dmesg - can you post your gamelist.xml to pastebin.com to take a look ?



  • @mitu I've never used pastebin before, so sorry if I got this wrong.

    https://pastebin.com/ccCcDn4E



  • @mitu I followed your lead and made my own mostly empty file myself and got the same results as you, scraping worked. The only thing I can think of is that maybe retropie/lr-pcsx isn't recognizing it because of it's size. But I've never heard of there being a limit on rom size.



  • @solidgear4 If the problem is with running the ROM, then you should enable verbose logging in the Runcommand launch menu and post the log on pastebin again (/dev/shm/runcommand.log), maybe there is an explicit error from lr-pscx-rearmed there.



  • I am having this exact same issue. And it's only this one game; the rest I scraped work just fine. Fhat the Wuck?



  • I have a Final Fantasy VIII (USA).PBP (2,160,718KB) and it is recognized and played fine (the last time I booted it up anyway, like 8-9 months ago). Have you tried redownloading source rom to recreate the PBP? or adding your current bin/cue and seeing if it shows up?



  • It's 5 months ago issue and it seems nobody is fixing this.

    It seems the emulationstation is having some limitation in detecting any bigger size file. My guess is file which exceeds 2GB, for instance, the single PBP of Final Fantasy VIII (2160718KB, around 2.06GB). The game can be launched and working fine. It's just the emulationstation frontend that unable to detect it.

    I am facing the same problem too and made such conclusion. Final Fantasy IX is around 1.75GB and emulationstation detects it but not Final Fantasy VIII.

    es_log.txt just showed this:
    lvl1: File "/home/pi/RetroPie/roms/psx/Final Fantasy VIII.PBP" does not exist! Ignoring.

    So need somebody to fix this.


  • Global Moderator

    @genzi0401 good news:
    https://github.com/RetroPie/EmulationStation/commit/84b1038c3fd5848befc0a137d09228c7d7600245

    i assume this is the same issue. please update emulationstation from source and it hopefully is fixed.



  • @dankcushions So I updated emulationstation. I am not sure if I done it nicely or not but.. it still do not work. Maybe my problem?



  • You should update from source using the emulationstation-dev package instead of the normal one. This because the former pulls using the master branch and the latter uses the stable branch.

    Go to the RetroPie setup menu, then Manage Packages and then go to the experimental section to install emulationstation-dev from source.
    If you update packages probably you will have to re-do this again. Not sure.


  • Global Moderator

    @hhromic looking at the commit I linked to, it looks like it has been applied to the master branch, so I don't think dev is needed? but yes, you will need to update via source.



  • @dankcushions yes, the commit you linked applies to master. I understand the scriptmodules work like this:

    • emulationstation uses the stable branch
    • emulationstation-dev uses the master branch

    Hence why I think the latter should be used for the very latest changes in master like that commit.


  • Global Moderator

    @hhromic oh, weird! ok - then yes, please follow @hhromic 's advice :)



  • @genzi0401 let us know if that solves it for you.

    Looks like this commit is quite fundamental for nowadays' rom sizes. Perhaps @BuZz can merge it into the stable branch so there is no need to go to the dev branch?



  • @hhromic The problem was reported only for Windows, on Linux I tested ES before this patch and there was no problem.


 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.