Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Wiimote/dolphin bar,



  • Hello everyone,

    I am on rpi3, retropie latest version, dolphin bar, wiimote and advancemame 1.4.

    I meet a problem with my wiimote under retropie and advancemame 1.4. Indeed, once it is configured in advancemame, as soon as I change the batteries of my wiimote, button 1, 2 and 3 buttons can not work. I have to re-set the buttons.

    Is this normal?
    Do you have a solution to solve this problem?

    Sorry for english, being french, i use Google translation.

    thank you in advance


  • Global Moderator

    @cyclair

    If you haven't already, the next time you pair your Wiimote to the Dolphinbar, try pressing the orange button in the battery compartment, rather than the '1+2' buttons. Pairing this way persists between sessions. It could also be that the mode is being changed when the Wiimote is powered down, so you might look at that as well.



  • Thank you for your quick reply.
    I will test tomorrow to remove the batteries and press the orange button, see what changes something.
    Thank you, I will come back to you to give you new ideas, this could be useful to other people with the same problem.



  • @cyclair dont remove the batteries. Sync with button in the battery compartment with the batteries in it. Then any time you change the batteries it should work fine. Try not changing the batteries while in the middle of a game, but even if you do it should still work fine.



  • I just tested with 3 games, Dunk Hunt, Jurassic and Bang synchronizing with the orange button, I had to do a restart without touching anything and this has to synchronize alone, it has keep the buttons in memory.
    I will stay a little more tonight with other games.
    I'm going to set up some games. Then turn off the system and change the batteries. Then check after synchronization.
    Thank you in any case, I will keep you informed of the progress of my problem to see if it is resolved or not.



  • So it seems to work, thank you.

    By cons when I change the video for a game, when I restart the game it does not keep the video configuration in time, is this normal?

    And I have to adjust game by play the touch of my wiimote. Is it possible to make a wiimote button setting that applies to all games and not play by game?

    should I edit the advmame-1.4.rc?



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.