Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

[solved] Prophet's Guile snes romhack only works with snes9x v1.53



  • {Solved
    There is lr-snes9x in optional packages, which is based on v1.54. Not to be confused with regular snes9x.
    }

    Hello everyone. I want play a romhack for SNES and I am not sure it will work correctly. Its Prophet's Guile based on Chrono Trigger: https://www.romhacking.net/hacks/362/

    I have a working rom now and the game starts. The problem is having the "wrong" or "too old" emulator will stop working somewhere in the middle of the game. And I don't want play until there to find it out. In the description it says the game will play fine on Snes9x v1.53, the version of snes9x2010 on RetroPie is Snes9x v1.52+. So, what should I do now? Are save files of v1.53 version compatible with those of v1.52+? If it stops working, I could decide to play on pc with that save file.

    I didn't include my current setup, as this question is general and not specific to my current RetroPie setup.



  • @thelostsoul you can install the latest lr-snes9x from the retropie menu and use that. Save files should work fine across versions, but not save states.



  • @lostless Oh ok, didn't know that its the newest version. In the RetroPie Docs for SNES didn't tell me what lr-snes9x version is uses. I just thought its an unoptimized version of original emulator. The Docs say:
    "lr-snes9x is an optional emulator that has MSU-1 support and more accurate emulation, but requires a sufficiently overclocked Pi 3 for guaranteed constant full speed emulation, and is sometimes too demanding for enhancement chip games."
    I don't overclock currently and "just may" overclock my Pi 3 just a little bit if I get my new case. So what would you recommend me doing?

    I could do the smart thing, use the "legacy" version until I am hitting the spot where the game stops working and then switch temporary for passing that point. But I have to spoil me somewhere to know that point. If the saves are working through all versions, this could solve my problem.

    Oh, I saw the newest snes9x version isn't "lr" compatible. So, will stay with old "lr-snes9x2010".



  • I am a bit confused. Is there a newer version than lr-snes9x2010, which is also "lr" compatible? The one I got from (I think it was) optional packages isn't "lr" compatible. All the RetroArch settings wasn't working, when I tried snes9x.

    I just need a version of snex9x based on v1.53 and it should be "lr" version. Does it exist?


  • Global Moderator

    @thelostsoul said in Prophet's Guile snes romhack only works with snes9x v1.53:

    All the RetroArch settings wasn't working, when I tried snes9x.

    This shouldn't be the case. Can you elaborate on what you experienced?



  • @mediamogul oh ok then, maybe I installed wrong version? I have now following to select from in installed snes emulators:

    lr-snes9x2002 (I think it was this one)
    lr-snes9x2005
    lr-snes9x2010 (default)
    snes9x

    I am currently not at home and will check where I got it exactly from and give any other needed information later. Just to be sure, does a version of snex9x v1.53 exist as RetroArch lr-snes9x?


  • Global Moderator

    @thelostsoul said in Prophet's Guile snes romhack only works with snes9x v1.53:

    Just to be sure, does a version of snex9x v1.53 exist as RetroArch lr-snes9x?

    As you say, lr-snes9x2010 claims to be 1.52+. I don't know exactly what they mean by plus, but I feel like they would have used a higher number if it meant anything beyond 1.52. If that's the case, anything after lr-snes9x2010 should work and that only leaves lr-snes9x.



  • @mediamogul So that means a version of snes9x at v1.53 or higher lr-capable and with support for RetroArch exist? I am still confused. Sorry if I ask this again, but I need to know this. Otherwise I don't need to go further and I just play it on pc. Thanks for the patience!

    Later if I am at home, I can provide more info about what I have installed. Sorry that I didn't include it, as my opening question didn't need those information.



  • @thelostsoul lr-snes9x is version 1.54. So try it with that.



  • Ok guys, everything is fine now. I had installed the wrong version, snes9x. Now I am at home and checked it; I had to scroll down further in optional packages to install lr-snes9x. It is exactly what I need and all RetroArch features are working and I can play the (short) game now. Thank you guys and sorry, the problem was my own fault.

    Just a small improvement idea, even if it means almost nothing. How about organizing the emulators in the install menu of RetroPie Setup Script the way all lr- emulators are on top, before all others. I just did stop searching after seeing regular snes9x and that was what confused me.



  • Just a last report. So, I have installed my new case and the temperature difference is like day and night, dropping around 30° Celcius (from 80° to 50°, but just a small test, it will heat up a little more, but you get the idea)! Its one huge heatsink (whole case is one big heatsink) and no extra boards installed. I am just happy, plus the right emulator and no over heating issues and no fan noise! Still not really well tested, but I can see clearly the benefit.

    Just someone is interested in it too, its very inexpensive also. My new case is: BIQU Aluminium Raspberry Pi Modell B for 11 Euros in Germany.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.