Please do not post a support request without first reading and following the advice in

Gameboy Games Cut Off/Zoomed In

  • All other emulators play roms OK. But the GB & GBA are cutting off the screen.

    I have checked the config.txt file and it shows 'disable_overscan=1'

    I have tried adjusting the resolution by selecting A on entering a game and adjusting the video mode for the emulator.

    It shows the Bezel centered correctly but the game within the bezel is too big and off center.

    Not sure what else to try? (I don't want to do anything which will change the appearance of the other emulators as they are fine). Is there anything else I can try?

  • Global Moderator

    @d4n Please give more information about your system - How did you configure your overlays ?

  • @mitu Apologies.

    I have a Raspberry Pi 3B.
    I am using a pre built image called Regalad V.4 64gb.
    Official Raspberry Pi power supply.
    Retropie 4.3.8
    USB Joystick connected
    Not overclocked.

    With it being a pre built image I did not configure anything. I have just tried to put this together as a quick present for someone. Im not familiar with raspberry pi or retropie really, but I am familiar with code and command line/terminal though so if there is anything I can provide which would be useful and is missing please let me know and I will of course do my best to get that info :)

  • @d4n put a hashtag in front of the disable overscan and test. Some emulators do that when that is enabled. Its better to use the manual adjustments as that doesnt create the issue of some emulators being zoomed in

  • @d4n also before you do that, when you select a game and it say press a button to configure, go into that and make sure you dont have and video settings set. If so remove them

  • @edmaul69 Thanks for the response. I have added the hash. Didn't make any noticeable difference. However I was able to get the screen to display almost perfectly through the retroarch settings. I pressed the hotkey and one of the buttons on the joystick to enter the menu and when I turned integer scale to on, and set the aspect radio width and height to 720x640 it displays pretty well inside the bezel.

    The only problem now is that every time I enter the game I need to re-enter the settings menu and choose these video settings. I attempted to save this configuration and it just exits the menu and puts me back in the game.

  • So it is saving the configuration. I can see in the menu mgba_libretro-2.cfg, -3.cfg, I followed a tutorial to set as default, however on opening the gba folder in terminal, I don't see any of the configuration saves I have made (which like I say, I can view when in the game). In this case I am using lr-mgba emulator. I am aware it can be used for gb, gba, gbc and sgb. I have checked all the folders just in case, and the only file with a recent time stamp is

  • OK I don't know if this is the best way of doing this but it seems to be working. The new config files were saving to configs/all/retroarch/config. The retroarch file being looked at is in gba/retroarch.cfg. I simply copied the content of the new config file and overwrote the content in retroarch.cfg with the new data. I kept back ups of the original files in case anything goes haywire. So far it seems to be just fine. Thanks.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.