Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Strange Hotkey Issue



  • My primary controller is a Rec Room Masters Xtension controller which is an arcade controller that is seen by Retropie as a keyboard. I also have a couple of iBuffalo gamepads. The controller has some dedicated buttons for Start, Select, Exit (Mapped to Esc), Menu (mapped to Tab), etc. I had my hotbutton key mapped to Select and everything has worked fine. All of sudden, today, out of nowhere, Select no longer worked as a hotkey. I tried plugging in my gamepad and Select works as a hotkey. Tried restarting, went through configuring input again in Emulation Station, no luck. I tried on a whim, changing the hotkey from Select to my dedicated Exit button. (which is mapped to the keyboard Esc button). Now, I can exit a game and pause a game without even hitting a hotkey. Ie. if I hit the dedicated Pause button, which is mapped to "P" it pauses without having to hold down the hotkey. Or if I hit the Exit button, which is mapped to Esc, I exit back to the main menu, again without having to hit the hotkey.

    Any ideas what is going on?



  • @jdruding It is strange that it would change, but a keyboard hotkey will be set using a statement inside one of several possible retroarch.cfg files. Check the file /opt/retropie/configs/all/retroarch.cfg and find a line that says input_enable_hotkey = "num5". What is yours set to? It should be set to whatever your keyboard arcade controller is sending when you press SELECT.

    There is a hierarchy of overrides with RetroArch, so depending on the system, or on the ROM, this statement could be changed in corresponding .cfg files. Also, you could check /opt/retropie/configs/all/retroarch-joypads. Give this page a read through for more details, and note that the gamepad hotkey config line is different than a keyboard hotkey config line. The gamepads use: input_enable_hotkey_btn =.



  • Ok, your hierarchal comment gave me enough clues to find something. In my troubleshooting, I noticed that Select + Start worked fine in NES so that made me think. In /opt/retropie/configs/all/retroarch.cfg, it is set correctly:

    input_enable_hotkey = "enter"

    However, in: /opt/retropie/configs/arcade/retroarch.cfg, it is set to Null:

    input_enable_hotkey = "nul"

    Setting it to "enter" still doesn't enable it to work, but it has the effect of also not allowing you to pause or exit without the use of a hotkey. My guess is defining it as null is what enabled that feature? So it seems to know the arcade retroarch.cfg has changed, but the hotkey still doesn't work. Incidentally, if I plug in my gamepad, I can exit using Start + Select.



  • @jdruding the config where it is set to nul will affect games you launch from the arcade folder. You have not mentioned emulators you are using, so be sure you are not launching games with a standalone emulator that ignores all of this.

    You say you had your hotkey mapped to select, but there is no select key on a keyboard, so your controller must be sending some keypress when you push select, right? What key is that? Normally, Select is the same thing as COIN on arcade emulators, and the MAME default key for that function is num5. You said above you have the hotkey configured for "enter". It needs to match your select key, so if it does, that's fine. I just like to follow MAME defaults if I can with my keyboard controller.

    Out of curiosity, why bother with a hotkey when you have dedicated buttons for these functions?



  • I was having the issue with lr mame2003. I mentioned "select", which is the dedicated button on my controller, but it maps to "enter". I have a dedicated "coin 1" button that is mapped to "num5".

    Regarding why i'm using a hotkey: I didn't know it was an option not to. :-) Now that I know though, I think I will stop using it. I just recent did an image back up so I'm just to going to restore to see if that gets me back to normal. I will probably then configure the hotkey to null, now that I know about this new feature, :-) but it bugs me that I don't know what caused this to begin with and am worried about some sort of corruption.



  • Ok, I noticed that the Retroarch setup screen was the blue menu (older version?) vs the green checkered menu so I was really worried about some sort of weird corruption so I restored the image from a backup and all is now well again.

    Friendly reminder of the importance of good backups! :-)

    Incidentally, does anyone know know what the difference is between the blue menu and the green checkered menu in Retroarch? Is the blue version an older version?


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.