Please do not post a support request without first reading and following the advice in

RetroArch/Image 4.4 issues

  • Hi everyone,

    I have an issue I can’t seem to fix. I’ve made a clean image of 4.4 on a pi3B+. At first boot I added a few roms, tested the controls and RetroArch worked fine. I built/setup my build and now my controller is being recognized as controller 2. My keyboard I used to help setup the image is being recognized as controller 1. No matter if the keyboard is plugged in or not. I can’t seem to get my controller as primary. I’ve tried every fix opinion I found on this forum, and nothing works. So in a nut shell RetroArch doesn’t respond to any hotkeys or exit games on the controller. Only the esc button on the keyboard. I’m lost and need help too fix this. My last image on 4.3 works perfectly, this new version is just pissing me off at this point.

    Thank you for any info.

  • @torment1979 are you using the joystick selection tool? If you are, retroarch changed the way it sees controllers and you need to remove the custom setup in joystick selection tool.

  • I don’t believe I am... I’m only using PS4 controllers connected with a USB cord. I’m not being dumb....but where and how would I remove the joystick selection tool? I’m willing to try anything at this point.

  • Global Moderator

    @torment1979 That's a different utility that has to be installed separately, so probably you din't have it on. I would reset the controllers' configuration from the RetroPie setup (in the Emulationstation package section) and re-configure the PS4 controller, so you'd start from the beginning with the controller configuration.

  • @torment1979 I Think the new kernel drivers see the ps4 controller as 2 controllers. One for the main controller and another as a motion controller. That could be the issue as well. I’ll have to test it. I mainly use a ps4 controller with a usb dongle.

  • Nothing worked too fix the issue. What I did was, rebuilt a new image. Then I used the ssh interface to do all of my keyboard commands. As soon as I connect a keyboard directly to the pi. RetroArch starts acting up.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.