Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

file number limit? can't transfer game art (possibly related can only access via sftp)



  • Pi Model or other hardware: 3b+
    Power Supply used: raspberry pi universal 2.5A, 5.1V
    RetroPie Version Used (eg 3.6, 3.8.1, 4.1 - do not write latest): 4.4
    Built From: Pre made SD Image on RetroPie website - retropie-4.4-rpi2_rpi3
    USB Devices connected: xbox 360 controller, keyboard
    Controller used: xbox 360
    Error messages received: varies between ftp clients but file transfer failed
    How to replicate the problem:

    So i have two issues but not sure if they are related.

    1. I can sftp into the pi (following the first install guide) and upload files but there seems to be a limit. I've uploaded roms and now want to upload game art and game lists (from a previous install). Part way through the transfer (whether using flashfxp or WINSCP)i get a file transfer error. Deleting other files on the card allows me to upload more files but the issue does not seem to be space (64gb card and the df command via console indicates only 40% of card being used. I also tried uploading additional large files and it works fine. The issue seems to be the number of files).
    2. I can't access the pi using samba (which i could do previously with 4.2 on older pi hardware).

    Any help would be greatly appreciated - thanks


  • Global Moderator

    I don't think there is a file system limit for the transfers, most likely a problem with the connection and the way that it's handled by the SCP client. Try using Filezilla for large transfers - it has a queue for transferring files and you can resume transfers.
    For the Samba problem, what's the error when trying to connect via File Shares from your PC ?



  • @djpi Retropie uses ext4 as file system except for the boot partition. Ext4 is only limited in its number of files by the number of inodes. You can show the number of used and free inodes with the command df -i. Example:

    $ df -i
    Filesystem       Inodes  IUsed    IFree IUse% Mounted on
    /dev/root       1908176 149337  1758839    8% /
    

    That means that my Retropie has 1,758,839 free inodes on its root partition. Home for one point seven million more roms. :D

    There's also a theoretical limit of 4 billion inodes and a configurable limit of 64,998 subdirectories in a directory, but I doubt that matters in your case. ;) So I second @mitu that your problem is likely to have another cause.



  • @mitu - thanks for the response. The error i get is "\RETROPIE is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. A device attached to the system is not functioning."
    i get the same error for \retropie or the actual ip address.

    I'd like to solve this problem but it seems like maybe there was something weird going on with the card being more full that i thought - either stuff wasn't deleting properly or i misread the file size / capacity stuff. Not sure. But i deleted a heap of larger files this morning and now the art and filelists seem to be uploading fine. Sorry to waste you time on that issue - but would still be keen to work out why i can't samba mount the pi....



  • @clyde thanks for this - helped me confirm that i definitely had space, once i deleted some larger irrelevant stuff


  • Global Moderator

    @djpi Are you using Win 10 Education/Enterprise edition ? There was an update some time ago (last year ?) which disables the ability to browse file shares without an user/password. If this is the case, I'd recommend keep using SFTP (FileZilla/WinSCP).



  • @mitu ahhhh - thats probably it!
    But things have now got more confusing. I've created a second install (using the same image file) and i can't log into the new one at all. Using the ip address or retropie (via winSCP) gives me
    "The server rejected SFTP connection, but it listens for FTP connections."
    (also can't samba mount but that probably makes sense).
    Both the computer and the pi on 192.168.0.X
    (i checked and got the new ip address on the new install)

    I get a similar error with filezilla. Gonna try downloading the image again and installing the newer image.... keen to hear any other ideas.


  • Global Moderator

    @djpi SSH is disabled for newly created images - see the docs at https://retropie.org.uk/docs/SSH/ for how to enable it.



  • @mitu wow - thanks again - must have done this on the prevoius install and somehow forgot :-/



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.