Please do not post a support request without first reading and following the advice in

Gamepad controller on Bartop Help

  • I have a bartop arcade that has a usb port and I would like to use a nintendo style gamepad for certain games. I have configured the controller and it works until I start a game. I think the problem is I have the option set to save games when exiting so it keeps high scores. I think when it loads it automatically selects the bartop joystick. Is there a setting in retroarch that will make both work at the same time?

  • @bassman6805 I don't have arcade controls (yet) but I do know that if you go into RetroArch while in a game for a specific systen you can go into the Controls menu and change User Device Type. Not sure if this will work in your situation but I always wondered if this was for this option.

  • Global Moderator

    As @TheDataCereal said, open the RA menu (Select + X) while in a game and change your Input settings, you probably want Player 1 to be the NES gamepad instead of the arcade Joystick. I don't think this is caused by the auto-save-on-exit settings.
    As an alternative, use @meleu's joystick configuration and you can configure - per system - which controller is which player.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.