Please do not post a support request without first reading and following the advice in

Trying to get ResidualVM residualvm-software to run full screen

  • Pi Model or other hardware: Raspberry Pi 3 B
    Power Supply used: 5V 3A USB power
    RetroPie Version Used: 4.4.1
    Built From: Built from RetroPie 4.4 img from, with script updated
    USB Devices connected: Rapoo T-series wireless keyboard ; X-Hyper 256GB USB drive ; Logilink Bluetooth dongle
    Controller used: Wii U Pro
    Guide used:
    Emulator: ResidualVM (residualvm-software)
    How to replicate the problem:

    1. Mount a new SD card with the 4.4 RetroPie img for Raspberry Pi 3 B, perform an initial setup and update the retropie-script to the latest version.
    2. Install ResidualVM from the Experimental menu
    3. Copy across ResidualVM game data across (tried with Grim Fandango, Myst III and Monkey Island 4)
    4. Launch ResidualVM and import the game data to create .rvm files for ES to launch
    5. Launch any of the .rvm files from ES using residual-software


    I'm trying to get ResidualVM residualvm-software to run full screen (in either 16:9 or 4:3 resolution), as every time I launch it, it just displays as small image in the centre of the screen. I've tried altering the screen resolution from the runcommand as well as changing any dispmanx settings but I just can't get it to display full screen. Unsure if this is a Raspian Stretch issue as I was able to get it to display full screen on Raspian Jessie on my old Raspberry Pi 3 (original model).

    Any other help or suggestions greatly appreciated!

    Thanks everyone.

  • same here, any tip?

    Start Residualvm
    Enter graphics
    Check override... And full screen ONLY
    Restart emulationStation


Log in to reply

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.