Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Xbox One controller triggers not working during configuration



  • Pi Model or other hardware: (B, B+, 2 B, 3, X86 PC etc..): 3 B
    Power Supply used: Canakit 2.5A power supply
    RetroPie Version Used (eg 3.6, 3.8.1, 4.1 - do not write latest): 4.4
    Built From: Premade SD Image (4.4)
    USB Devices connected: Corsair Keyboard & Xbox One Controller (Wired)
    Controller used: Xbox One S Controller (Wired)
    How to replicate the problem: Turn on the Pi with the fresh SD image, it then asks to configure controller. When you hold a button, "MICROSOFT X-BOX ONE S PAD" appears briefly before going into configuring. Then, once you get down to Left Trigger, and I push down the left trigger and release, it sets Left Trigger to Axis 2-, Right Trigger to Axis 2+, and it skips the Left Thumb.

    I have tried setting up the controller with both Xpad (after updating the script from the recent bug), then I removed it, installed Xboxdrv, and tried setting it up again, but it still won't let me set it up properly.


  • Global Moderator

    @aditkrator Can you check my update in the other topic to see if the workaround I posted there works for you also ?



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.