Please do not post a support request without first reading and following the advice in

Controllers/keyboard not working for 30 sec when I start emulators

  • Hi. Recently my pie has been acting up. I recently got two logitech F310 controllers and they worked fine in the menus but didn't work in the emulators. I took the lazy route and just formatted my SD card and reinstalled fresh version of retropie and everything worked as intented when I tried to play a SNES game with my new controller.

    I then proceeded to update retropie, all packages and drivers and add roms for different systems. Now the weird thing is that I tought my controllers stopped working but I have realized that even though they show up as configured when starting the emulator, controller and keyboard dont seem to register any inputs AT ALL for about 30 sec after starting an emulator. After that they work like normal, no delay or anything. I tried to investigate further and I've found out that if i unplug and plug the keyboard/controller back after i start an emulator. It works as normal right away. Any Ideas as to what might be going on and how I can fix it?

    I do realize I could probably just format everything again and hope that it's working but I want to find out what the problem is so I don't have to regularly reinstall retropie to keep it working like normal. Any help/suggestions welcome!

    and I should also add I'm very new to retropie as well as unix so keep that in mind :)

  • @rive Do you have them plugged in the correct usb ports on the pi ?

    0_1530679382705_Rasp Pi usb ports.png
    Port 0 is for the first controller and port 1 for the second. If your using a pi 3 . You never specified.

  • I had the same issue with the same controller. I suspected it was the Xpad driver and was correct after updating everything else individually.

    I'm not certain it will fix the issue, but here is my working Xpad driver's entire folder.

    Working Driver:

    These go in /opt/retropie/supplementary/xpad, but everything in there requires Root access to alter.

    SSH Method:

    I hope I was helpful.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.