Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Libretro stopped working on 16.04 after latest drivers update (SOLVED)



  • @mitu I was on latest stable release (4.4), then I've updated to 4.4.2 and updated retroarch package too. Same results.


  • Global Moderator

    @rael_gc Between 4.4 and 4.4.2 there isn't much difference - it's the same RetroArch version. Another workaround is to use a Wayland enabled session - are you using the default (Unity) desktop environment ?

    EDIT: Can you try re-installing from source RetroArch, but edit the module script ($HOME/RetroPie-Setup/scriptmodules/emulators/retroarch.sh, line 40) and remove the 1.7.3 from the git checkout so you get the latest version ? Then re-test (using the same gl/gl2 video driver) and see if the issue persists ?



  • @mitu Removed the 1.7.3 from module script, got from master, reinstalled and still the same issue.

    Emulators running outside Libretro (pcsx2, dolphin, etc) are working fine (as previously they were).

    Yes, I'm using default Unity. If I correctly remember, Wayland has no support on 16.04.



  • In this meanwhile, I've reverted the driver update getting the latest working version of the files and installed them. It worked.

    I've downloaded and installed the following files:

    • libegl1-mesa_17.2.8-0ubuntu0~16.04.1_amd64.deb
    • libegl1-mesa_17.2.8-0ubuntu0~16.04.1_i386.deb
    • libegl1-mesa-dev_17.2.8-0ubuntu0~16.04.1_amd64.deb
    • libgbm1_17.2.8-0ubuntu0~16.04.1_amd64.deb
    • libgbm1_17.2.8-0ubuntu0~16.04.1_i386.deb
    • libgl1-mesa-dev_17.2.8-0ubuntu0~16.04.1_amd64.deb
    • libgl1-mesa-dri_17.2.8-0ubuntu0~16.04.1_amd64.deb
    • libgl1-mesa-dri_17.2.8-0ubuntu0~16.04.1_i386.deb
    • libgl1-mesa-glx_17.2.8-0ubuntu0~16.04.1_amd64.deb
    • libgl1-mesa-glx_17.2.8-0ubuntu0~16.04.1_i386.deb
    • libglapi-mesa_17.2.8-0ubuntu0~16.04.1_amd64.deb
    • libglapi-mesa_17.2.8-0ubuntu0~16.04.1_i386.deb
    • libgles1-mesa_17.2.8-0ubuntu0~16.04.1_all.deb
    • libgles2-mesa_17.2.8-0ubuntu0~16.04.1_amd64.deb
    • libgles2-mesa_17.2.8-0ubuntu0~16.04.1_i386.deb
    • libgles2-mesa-dev_17.2.8-0ubuntu0~16.04.1_amd64.deb
    • libosmesa6_17.2.8-0ubuntu0~16.04.1_amd64.deb
    • libwayland-egl1-mesa_17.2.8-0ubuntu0~16.04.1_amd64.deb
    • libwayland-egl1-mesa_17.2.8-0ubuntu0~16.04.1_i386.deb
    • mesa-common-dev_17.2.8-0ubuntu0~16.04.1_amd64.deb
    • mesa-vdpau-drivers_17.2.8-0ubuntu0~16.04.1_amd64.deb

    I added links just to the first 2, but you can follow they format and replace arch, package name and version in the URL to get the others.



  • Sounds like changes in the newest installed OpenGL made it incompatible with LibRetro (the same issue affecting 18.04).

    For some days, I'm preventing to receive the new drivers again using apt-mark hold:

    sudo apt-mark hold libgl1-mesa-dri libglapi-mesa libgles1-mesa mesa-vdpau-drivers

  • Global Moderator

    @rael_gc There are a few issues opened on the RA github issue tracker w.r.t. Wayland and KMS, not only on Ubuntu, but from I've seen they manifest themselves as crashes ([1],[2]). There is also a solved issue for KMS/EGL [3] after a recent Mesa update (that's why I suggested getting the latest code).

    I'll try to reproduce the bug, but I'll have to find some time to install Ubuntu and test through to see if there is any - proper - solution to this problem.
    Thank you for the time and effort of following my instructions - though they've not helped at all to solve the problem - and for narrowing the updated packages that trigger the issue.

    [1] - https://github.com/libretro/RetroArch/issues/6763
    [2] - https://github.com/libretro/RetroArch/issues/6972
    [3] - https://github.com/libretro/RetroArch/issues/4790



  • @mitu Oh, nice, thanks for pointing all these issues, I'll follow them! And thanks for your time and patient to answer!

    Hope that if someone got the same issue, my above instructions to downgrade can help.


  • Global Moderator

    @rael_gc OK, so I did a quick test on an 18.04 install. I know it's not 16.04, but since the symptoms are similar to the Libretro not yet read for Ubuntu 18.04 topic, I tried shooting 2 rabbits at once.
    The setting that seems to cause the problem is video_threaded=truein the Retroarch config file. If I put video_threaded = false, then the video is back and everything seems to work ok.

    If you have the time, you could upgrade the packages again, then modify this setting in /opt/retropie/configs/all/retroarch.cfg and give it a try.


  • administrators

    @mitu I will change the default setting for x11 non arm targets in RetroPie-Setup. Thanks. On faster machines this may well be better set to false anyway.



  • @mitu It worked! Sorry for my late response!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.