Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Amiberry, whdboot, Mouse and Joystick "none" (ps4 joypad)



  • I have struggled for two days figuring this out. I have Amiberry loaded. Every time I load a whdboot game, and open the Settings, there's no Input. Port 0 [Mouse] and the three joysticks are set to "None". I can reselect them manually every bootup and they turn up as [R] meaning the controller config was found, and it works fine in game. But it gets old quick to have to select them manually every startup.

    I tried to read what little info I could find on the Amiberry wiki and googled hard. hostprefs.conf is definitely set to CONTROLLER_1=joy1 and CONTROLLER_MOUSE_1=mouse.

    This guide;
    https://github.com/midwan/amiberry/wiki/Using-Amiberry-WHDBooter-with-RetroPie-(Step-4)
    ... refers to the "Amiberry Wiki Page", and I dwelled there too. For all I can see, it should work, it just doesn't.

    I tested to save a new .uae config and it seems ok;
    joyport0=mouse
    joyport0_autofire=none
    joyport0_friendlyname=Mouse
    joyport0_name=MOUSE0
    ;
    joyport1=joy1
    joyport1_autofire=none
    joyport1_friendlyname=Sony Interactive Entertainment Wireless Controller
    joyport1_name=JOY1

    I tried to add these lines to hostprefs.conf but it didn't do anything.

    Then I went to https://github.com/midwan/amiberry/wiki/Setting-up-Input-Controllers and it say;
    "For RetroPie, you should select /opt/retropie/configs/all/retroarch/autoconfig/"
    ... but that just turns up empty.

    I read;
    https://github.com/midwan/amiberry/wiki/WHDLoad-Booter-(WHDBooter)-F.A.Q.
    ... and it have the question "I have issues with my controller not being correctly selected by-default on loading each game, and/or I would like to use a real mouse/specific controller for mouse games. How do I do this?" but the answer didn't help. I even tried to remove the joy2 and joy0 from hostprefs.conf but nothing happens when I did.

    Finally I read;
    https://github.com/midwan/amiberry/wiki/WHDLoad-Auto-booting
    ... but it didn't help either.

    Pi Model or other hardware: Raspberry Pi 3
    Power Supply used: 2.4A usb charger
    RetroPie Version Used: v4.4.2
    Built From: Pre made SD Image on RetroPie website
    USB Devices connected: Logitech k830
    Controller used: Dual Shock 4 (via internal bluetooth)
    Emulator: Amiberry (from binary)


  • Global Moderator

    @jemym said in Amiberry, whdboot, Mouse and Joystick "none" (ps4 joypad):

    "For RetroPie, you should select /opt/retropie/configs/all/retroarch/autoconfig/"
    ... but that just turns up empty.

    If you configure your gamepad in Emulationstation, it shouldn't be empty. Otherwise, please give more details about your system as requesed in https://retropie.org.uk/forum/topic/3/read-this-first.



  • I added the system information in my original post (sorry).

    When I select "select /opt/retropie/configs/all/retroarch/autoconfig/" the path is changed to /opt/retropie/configs/all/retroarch/autoconfig/---"

    When I browse to the folder in samba it looks weird; its filled with subfolders;

    "\?\UNC\retropie\configs\all\retroarch\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig\autoconfig"

    I went back to create new controller profiles for my joypad and keyboard, then I changed the paths in Amiberry to;
    path=/opt/retropie/emulators/amiberry/kickstarts/
    config_path=/opt/retropie/configs/amiga/amiberry/conf/
    controllers_path=/opt/retropie/configs/all/retroarch/autoconfig/
    retroarch_config=/opt/retropie/configs/all/retroarch.cfg

    And clicked "Rescan Paths".

    Just to be sure I rebooted the system and tried a new WHDLoad game.

    It had no effect. Mouse and joypad still turns up as "None".



  • @jemym said in Amiberry, whdboot, Mouse and Joystick "none" (ps4 joypad):

    config_path=/opt/retropie/configs/amiga/amiberry/conf/

    I changed it to config_path=/opt/retropie/configs/amiga/amiberry/

    Now I note that when I restart the emulator (by clicking Restart in the Amiberry GUI) the mouse and joystick are added as they should. But that still removes the point since I still have to use the UI to get the joypad to activate.



  • @jemym Have you tried installing Amiberry from source? Here is a a post where a user reported doing so fixed a similar issue to yours.



  • @dudleydes Confirmed!

    Installing from source fixed the issue immediately, at least for joypad. Mouse does not activate (tested with Lost Patrol and Lemmings).



  • @jemym Could you check your hostprefs.conf file with the one at the Amiberry github? You can find it in /opt/retropie/configs/amiga/amiberry/whdboot.

    I found that I needed to swap the values for CONTROLLER_MOUSE_1 and CONTROLLER_MOUSE_2 to get the analog stick on my PS3 controller working as a mouse in Lemmings, Cannon Fodder, Syndicate etc..



  • @dudleydes I realized that I had disabled controller 2 and 3 and when enabling them mouse is now also enabled by default.

    By default mine was set to;
    CONTROLLER_MOUSE_1=mouse
    CONTROLLER_MOUSE_2=joy2

    The one on Amiberry github is set to;
    CONTROLLER_MOUSE_1=joy1
    CONTROLLER_MOUSE_2=joy2

    I had to set Mouse to my joypad (wireless ps4 joypad) to my mouseport, and also declare to Amiberry that its a mouse.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.