Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

How do I apply shaders?



  • @mitu

    Yes I am using a laptop with ubunntu 18.04

    My pc is a laptop lenovo ideapad 320 running linux ubuntu:

    processor: AMD A10-9620P
    Ram: 8Gb
    video card: AMD Radeon R7
    Hard disk: 1Tb


  • Global Moderator

    @tackskull Normally the RetroArch shaders should be in /opt/retropie/configs/all/retroarch/shaders and that folder should look like this. So check that you have those files in that folder and also if your /opt/retropie/configs/all/retroarch.cfg has any value for video_shader_dir (mine is empty on a Raspberry Pi).

    EDIT: I now realise that the RPI has a different branch of the shaders repo, specifically for the Raspberry PI, so the listing I provided does apply in your case. For Ubuntu, it gets another branch, which has more shaders than the ones included on the PI. You should still be able to load them, you just need to browse the shader folders when you use Load Shader Preset from the RGUI. There's a whole crt folder with *.glslp file that you can load as shaders and are suitable for retro-gaming.



  • Guys, thanks for the answers, but anyway on each folder I get "no item". I have tryed all the ways you guys told me, but I just get "no items"...... I tryed to download the retropie shaders pack from the internet, but the most of the file had to be replaced so that mean I already have all the shaders files but my retroarch just can't see them..... can you tell me clearly step by step what I have to do to let retroarch see the shaders files?


  • Global Moderator

    @tackskull 1st thing to try is re-install RetroArch. If you still don't see any shaders, then maybe a log of the installation would be helpful.
    EDIT: Logs for the installation/reinstallation of RetroArch can be found in ~/RetroPie-Setup/logs, it should be one of the last (by date) files in that folder.



  • Ok, I have unistalled retroarch and the I reinstalled it. The problem is still there, retroarch can't see shaders, in each folder it say "no item".

    I am posting you via dropbox my most recent log file (just after reinstall retroarch) https://www.dropbox.com/s/h9x2odzt2gfncjq/rps_2018-08-10_223154.log?dl=0

    Please HELP :( :( :(


  • Global Moderator

    Looking at the installation log file, it seems that shaders are already up-to-date in the /opt/retropie/configs/all/retroarch/shaders folder and the install script does not install them again, so something else is up, most likely a configuration issue.

    Can you post on pastebin.com:

    • /opt/retropie/configs/all/retroarch.cfg
    • Launch a ROM with verbose logging enabled (via the Runcommand launch menu), try to load a shader, then exit. Post the /dev/shm/runcommand.log file resulted after this operation.


  • I changed linux system. Basically from Ubuntu I moved to Ubuntu mate and I have reinstalled retropie . Now I am able to see the shaders and to load them. I run a game, I press select+X for retroarch menu, I go on shaders and I choose one. The little problem is that nothing change on the game's look and if I get back on retroarch I can see the shaders is still loaded. This shaders trouble is taking me in to.


  • Global Moderator

    @tackskull Shaders are working when you have the gl video driver selected. Do you have that enabled in RetroArch ?



  • @tackskull Do you select 'apply changes' after choosing a shader?



  • Yes I do but nothing change


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.