Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

[Solved] "Abuse" (Retropie Porting) does not work



  • Pi Model or other hardware: Raspberry Pi 3 B
    Power Supply used: 2.5V
    RetroPie Version Used (eg 3.6, 3.8.1, 4.1 - do not write latest): 4.4
    Built From: Pre made SD Image on RetroPie website
    USB Devices connected: keyboard, mouse, joypad
    Controller used: dragonrise
    Error messages received: see below
    Log found in /dev/shm/runcommand.log (if relevant):


    Parameters:
    Executing: pushd /opt/retropie/ports/abuse/abuse_datadir; /opt/retropie/ports/ab
    use/abuse; popd
    /opt/retropie/ports/abuse/abuse_datadir ~
    Abuse version 0.9
    Specs : main file set to abuse.spe
    Protocol Installed : UNIX generic TCPIP
    Lisp: 527 symbols defined, 99 system functions, 319 pre-compiled functions
    Joystick : detected
    (load "abuse.lsp") [...................... ]
    (load "abuse.lsp") [................................ ]
    (load "abuse.lsp") [........................................]
    Engine : Registering base graphics
    abuse 0.9
    Sound: Enabled
    1 joysticks on system

    • joystick 0 (controller) : DragonRise Inc. Generic USB Joystick
      No such item nums0016.pcx in file art/icons.spe
      ~

    Guide used: n/a
    File: see below
    Emulator: abuse
    Attachment of config files: n/a
    How to replicate the problem: see below

    I installed "Abuse" and the installation was successful, I had to modify the file /opt /retropie/configs/ports /abuse/abuserc under datadir modifying it like this:
    ; Location of the datafiles
    datadir = /opt/retropie/ports/abuse/abuse_datadir
    In the directory abuse_datadir I added all the necessary directories and files taken here: abuse.zoy.org
    I launched the game that does not start returning this error:
    No such item nums0016.pcx in file art / icons.spe
    (The same thing happens with the original DOS game file)



  • Fixed: I downloaded Satan Paint (spaint.exe) and dos4gw.exe (to run spaint.exe under DOS). I used DOSBox to run spaint.exe and I created the .pcx (blank image) that were missing in the icons.spe file (from the nums0016.pcx to the nums0045.pcx), so I created a new icons.spe file and now it works correctly .
    Here is the modified icons.spe file to work: https://github.com/Xenoveritas/abuse/files/2264348/icons.zip



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.