Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

SD image restored in a new bartop, controller not recognized in retroarch



  • @clyde
    this is my dainput.ini file:

    [KEYBOARD]
    KEY_UP = 273 114 2
    KEY_DOWN = 274 102 2
    KEY_LEFT = 276 100 1
    KEY_RIGHT = 275 103 1
    KEY_BUTTON1 = 306 97 3
    KEY_BUTTON2 = 308 115 1
    KEY_BUTTON3 = 32 113 4
    KEY_START1 = 49 0 9
    KEY_START2 = 50 0 0
    KEY_COIN1 = 53 0 2
    KEY_COIN2 = 54 0 0
    KEY_SKILL1 = 304 119 0
    KEY_SKILL2 = 122 105 0
    KEY_SKILL3 = 120 107 0
    KEY_SERVICE = 57 0 0
    KEY_TEST = 283 0 0
    KEY_RESET = 284 0 4
    KEY_SCREENSHOT = 293 0 0
    KEY_QUIT = 27 113 10
    END
    

    actually IT IS DIFFERENT from what I set up some hours ago! I probably did it with emulationstation running and it screwed up buttons assignment.
    However now I fixed it with the correct button assignment:

    [KEYBOARD]
    KEY_UP = 273 114 2
    KEY_DOWN = 274 102 2
    KEY_LEFT = 276 100 1
    KEY_RIGHT = 275 103 1
    KEY_BUTTON1 = 306 97 1
    KEY_BUTTON2 = 308 115 3
    KEY_BUTTON3 = 32 113 5
    KEY_START1 = 49 0 9
    KEY_START2 = 50 0 0
    KEY_COIN1 = 53 0 10
    KEY_COIN2 = 54 0 0
    KEY_SKILL1 = 304 119 0
    KEY_SKILL2 = 122 105 0
    KEY_SKILL3 = 120 107 0
    KEY_SERVICE = 57 0 0
    KEY_TEST = 283 0 0
    KEY_RESET = 284 0 4
    KEY_SCREENSHOT = 293 0 0
    KEY_QUIT = 27 113 6
    END
    

    Now COIN and QUIT buttons seem to work, but game e.g. dragon's lair plays on its own like random scenes without asking for my input.
    I don't know why since in the other bartop works perfectly :-\



  • Luckily I still have access to the other bartop and just checked that Dragon's lair is working strangely even there!!



  • the problem is daphne ill try find the thread for you to compile the version i fixed it in



  • instructions for compiling the daphne fix i done https://retropie.org.uk/forum/topic/8578/daphne-dragonrise-encoder-issues/17



  • @grant2258 thank you very much for the link.
    I have compiled the fix you made and hopefully daphne works, but like before the game seems to play some scenes and not from beginning. Joystick works but I remember that e.g. dragon's lair flashes in the direction you have to move, and it won't flash anymore.
    Reset button does not work, quit, coin and start are working.

    I don't know why there are all these issues.. I remember I was happy because all the laserdisc games I had were working :(


  • Global Moderator

    @papinist said in SD image restored in a new bartop, controller not recognized in retroarch:

    dragon's lair flashes in the direction you have to move, and it won't flash anymore.

    Any flashes that are missing can be enabled from the service menu by pressing the '9' keyboard key. 'Dragon's lair' also has some flashes that were included in the animation. Those obviously can't be altered. Scene order may be able to be changed from the service menu as well, but I believe that is mostly controlled by the ROM version.



  • Maybe my memory was bad.. I started DL2 and it has flashes and directions on screen, and it works perfectly. Also super don quixote works.
    I have to check them all and see what works and what not.

    Thanks for now guys!

    EDIT: I found an explanation on how Dragon's Lair sequencing works. I thought it was palying scenes randomly but found out that it's the game's behaviour :)
    Sorry for begging without checking! At this point I only have Space Ace with black screen after some loading scenes, thayer's quest that won't get any commands and us vs them that asks for a 'trigger' but no one of the three buttons is the one it wants!



  • @papinist If you don't know it already, you should check out the DRAGON'S LAIR ENHANCEMENT ROM SET VERSION 2.1. It changes/enhances many features of Dragon's Lair.

    You can even install it next to the original and let them both use the same lair.m2v by pointing lair.txt to it, thus saving much space that a second m2v would occupy. For example, my ~/RetroPie/roms/daphne/dle21.daphne/dl21.txt points to ~/RetroPie/roms/daphne/lair.daphne/lair.m2v:

    ../lair.daphne/
    
    151     lair.m2v
    

    The .. stands for "one directory level up", relative to the location of dle21.txt.



  • @Clyde I was just reading the other pages on the website I found and discovered that enhanced version. I will sure try it today and see how it works. Do you know if this could be used with Space Ace too? Don't know what problem I have but it does not work at the moment.
    I should edit the thread title because this is mostly a daphne related problem :)



  • @papinist DL21 only works for DL, but on http://www.dragons-lair-project.com/tech/ you can find enhanced versions of DL2 and SA as well. Look under "ROM Updates".

    I think a separate thread would be better for your Daphne issues.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.