Please do not post a support request without first reading and following the advice in

Clone ROM Changed(?) After Scraping

  • Hello, so I noticed that my TMNT (2 player, Arcade (FBAlpha) did not have a description scraped. So instead of typing out something, I decided to individually scrape it though Emulationstation. I have my parent ROM hidden [], renamed as tmnt.ZiP to hide it from the list. After I scraped tmnt2po, the ROM would no longer launch. I went in and downloaded fresh ROM files thinking maybe FBAlpha updated and my romset went bad, but it still did not work. So I renamed tmnt.ZiP back to, it reappeared, and the clone ROM worked again. Not sure if the scrape I did on tmnt2po changed a file to require and not tmnt.ZiP. I thought this didn't matter.

    Any suggestions?

  • Tried updating Retropie, but this is still happening for TMNT.

    Weird though, all my other Hidden Parent Roms via the .ZiP method still allow the Clone to run.

    I have this set for TMNT: Turtles in Time, Sunset Riders, Simpsons.. they all work fine. is the only one, which I scraped recently using Emulationstation.

    Is there a file that is telling the system "You must have, not tmnt.ZiP"?

  • Global Moderator


    I'd always be hesitant to ever recommend changing file names for arcade ROMs at all, but if this was working for you then I don't see any reason why altering the metadata in Emulation Station would change anything. Do you keep backups of your system? If so, try reinstating the altered game list file for ES prior to the change and see what effect it has. Just remember to shut down ES before making the switch.

    Edit: Something else that may shed light on the issue; post the contents of /dev/shm/runcommand.log and /dev/shm/ after launching the renamed file that won't launch, as well as one of the renamed files that will launch.

  • @mediamogul

    Some weird stuff happening. So I noticed other Clones are not working unless the parent is named .zip vs .ZiP.

    Vendetta 2 Player appears to not work no matter what right now on lr-fbalpha but will work on lr-fbalpha2012. Strange..

    Turtles in Time and Sunset Riders will still run their Clones on lr-fbalpha with the Parent named .ZiP.

    This appears to be stranger than I expected.

    Update: So I found a short cut by placing all the Parent ROMs in the BIOS folder because lr-fblapha will go there to get them. They do not show up anymore in my list on ES. Vendetta not working on lr-fbalpha is its own problem I think. Perhaps ROM related.

  • @greenhawk84 This is a very nice idea. Thank you for sharing. Sometimes I would like include clones only.

  • @thelostsoul said in Clone ROM Changed(?) After Scraping:

    @greenhawk84 This is a very nice idea. Thank you for sharing. Sometimes I would like include clones only.

    It seems like a better route vs renaming ROMs to .ZiP. The downside is this method is not going to work for all emulators. Good thing lr-fbalpha is a very versatile core. It has taken over as the default arcade core on my setup. Mame2003-plus is creeping in on some key games.

  • Global Moderator


    That's a very nice trick. Until now, I was under the impression that AdvanceMAME was the only arcade emulator where the BIOS files and clones could reside away from a main ROM grouping. Thanks for sharing this.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.