Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

map: vt02 => fb0 when booting directly to emulator



  • I have been trying to boot directly to BasiliskII with RetroPie. I tried adding

    /opt/retropie/supplementary/runcommand/runcommand.sh 0 _ SYS _ macintosh ~/RetroPie/roms/Macintosh/Start.txt

    (there is no space between _ & SYS & _, I just added it because it would have replaced it with italics if I didn't)

    to the top of the autostart.sh file and when I do so it works for about two seconds, then the screen goes blank and gives the message map: vt02 => fb0 in the top left corner. This error does not occur when I first start emulationstation and then select Start. From what I've read, I think this has to do with the fact that no framebuffer was initialized because emulationstation was not started. BTW, I tried adding

    con2fbmap 1 0

    to rc.local above

    exit 0

    like other similar posts suggested but it did not fix anything.


  • Global Moderator

    @willmurray461 said in map: vt02 => fb0 when booting directly to emulator:

    I tried adding
    /opt/retropie/supplementary/runcommand/runcommand.sh 0 _SYS_ macintosh ~/RetroPie/roms/Macintosh/Start.txt

    Linux is case sensitive. Try:

    /opt/retropie/supplementary/runcommand/runcommand.sh 0 _SYS_ macintosh ~/RetroPie/roms/macintosh/Start.txt
    


  • Sorry, I typed that wrong. I did know that Linux is case sensitive and I wrote macintosh with a lowercase m on my actual pi.


  • Global Moderator

    @willmurray461 I can reproduce this, but the reason why it happens is still unclear. Works from ES, but not called directly.
    I don't think the con2fbmap 1 0 call is necessary, /dev/fb0 is already bound (by default) to /dev/tty1and it's probably why it doesn't make a difference or solves the problem.



  • After some more experimenting, I noticed that after a clean install it would work the first time, but never again. Also, I noticed that if I set the refresh rate in the basiliskii.cfg file to dynamic (frameskip 0) and constantly moved my mouse it wouldn't give me the error. What would happen is the screen would turn completely white and then as I moved the mouse it would replace horizontal chunks with the emulator screen. I could do this until all of the screen was visible, but when I tried to shut down, the screen would go black, the mouse would invert color and I could not close the emulator or reboot.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.