Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • Hello friends

    Recently i started to use Retropie, i thought it was a good idea use a dualshock 3 with it. Sadly, when i bought one from my local market, and i tried to connect it with my retropie build, it recognises it as a "Shanwan controller" (usb connection). Obviously i came back to the local store and demanded a refund. They say its original, but retropie say its fake. Is there a possibility that linux is identifying mi controller wrong and its real? They are menacing me with a demand if i don't desist to claim its fake. Please help!

    Regards!

  • Global Moderator

    @koolhass It's called a 'clone' or more exactly a 3rd party controller, though probably some will consider it as 'fake'. Unless they specifically advertised it as 'Genuine Sony', I don't see it as fake. They're pretty common and they're supported just as a genuine PS3 controller.


  • Yeah, they advertise it as a Genuine Sony, it has the official logo, package and everything, and they charge for it like an original. So, its undeniably a falsification? There is no possibility that Raspbian recognise a Sony controller like a Shanwan? ( i already tested an original one and appears in command line as manufactured by Sony).

    I'm all eyes XD


  • @koolhass Same happened here. It is a fake, unfortunately. I complained in my case, but didn't manage to go anywhere with it.


  • @koolhass can you take good pics of the decal and plastic around the decal. Also a direct pic with flash of pin hole on the back? Plus a side view of the 4 lights? I can tell you if is a bootleg. I have seen hundreds of them. And yes people sell bootlegs as real and Un-knowledgeable people cant tell the difference.


  • @edmaul69 yes, in a couple of hours i'll post some pictures



  • @koolhass fake. Official ones arent 5v. The sticker aint even real looking. And look at the lights. They have lines. The real ones are perfect.


  • @koolhass also looking at the pinhole it doesnt appear to have the reset rubber button in it.


  • I don't think they even make those anymore do they? I would assume at this point you could only find refurbished, used, or clones.


  • Yeah compared to other bootlegs i have seen, this one isnt even good. The quality is terrible.


  • Ok, it's what i thought. So now im looking methods to prove that it's a fake , sony telephone support it's a disaster, no help at all. Im sending it to official repair service to serial number check. Any other ideas? How to prove that raspbian command line it's a good source of information. What is thw technical background of it?. Thanks a lot for your support!


  • @koolhass How much did they charge for a new "dualshock" if you are willing to tell?


  • @thedatacereal 45 us dollars more or less


  • @koolhass the label states 5v and has absolutely no ul rating on the sticker. That alone proves its fake. If a mass produced electronic device doesnt have a ul rating its a fake.


  • @koolhass so this shows 5v so this might still be a fake but notice the fcc and ul logos. Yours are missing those and that makes it 100% fake no questions asked.

    0_1535614935682_1AC23F54-24D9-4445-ACDC-344A72E31D38.jpeg


  • @Koolhass I don't think you're getting anywhere. I'm sorry to say but it's your fault, not sony. If you just want to sue the shop that sold you the gamepad as "genuine" you can, of course, but nothing more. Sony has nothing to do with this, I'm sure they are quite aware of these shitty gamepads.

    If you don't think you can differentiate a legit pad from a fake one bring a friend to the store when you go buy one, to avoid further surprises :)


  • @edmaul69 I recently bought a controller with the same label, but this it is not pairing at all.
    When I connect it, it does not vibrates at all, and only the first light flashes. Thats odd.
    Any idea of how to pair and register this controller?

    I have two shanwan clones and they work fine with the driver.
    I also tried to pair this new one with original drivers, and all of the package but with no luck (actually I bougth 2 controllers and have the same behavior).

    Inside the es_input I notice:
    Playstation(R)3 controoler (an original ps3 controller)
    SHANWAN PS3 GamePad (for the shanwan clone)
    PS3 Controller (for this one)

    Any ideas?

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.