Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Really weird AdvMESS/BBC micro config bug



  • Have you thought of trying a different keyboard ?
    All of your problems seem seem to stem from the keyboard.
    For what it's worth, I tried Thrust - the filename is "Thrust (EU).ssd", and it worked perfectly. The shift key operated thrust, the spacebar for shields, Return for fire, caps lock for rotate left, ctrl for right. All worked fine on my little Rii X8 wireless keyboard.



  • @John_RM_70 How could it possibly be the keyboard? The keyboard works fine, it's only assigning a control to a joystick button and keeping it assigned that's failing.



  • On another note, in the advmess.rc, if you removed the game name part in the config (ie: _Thrust, _Tempest) it becomes a universal control for all bbc micro games



  • @edmaul69 Yeah, I figured that, but sadly the BBC didn't even nearly have uniform game controls. Might still be a timesaver to set up a default of ZX*/ and Enter, though.



  • @SpudsMcToole So keyboard shift works but 'joystick' shift does not for you.

    The only difference that I can see between your setup and mine is that I use xboxdrv. That means that once I got the shift key on my keyboard to work, I was home and hosed. Using xboxdrv meant that my joystick button was 'tied' to the keyboard shift key and I wasn't reliant on advmess' joystick implementation for the shift key.

    If you are desperate for the BBC Micro to work, you could set up xboxdrv to work just for the BBC Micro or even just for individual BBC Micro games that hardwire/use the shift key.

    It is a reasonable amount of work to set up, but you've demonstrated the perseverance so far that suggests to me that you are an ideal candidate for the xboxdrv program!

    What kind of joystick are you using?



  • @spud11 Haha. I'm willing to wade through quite a lot of code for Pi stuff generally, but xboxdrv is a league too far for me. Have tried a couple of times in the past and run away screaming. I've never seen anything so incomprehensible in my life.

    (I'm using a double arcade joystick.)

    At the worst, what I've got so far means having to manually set one key every time I load one of a small handful of games. Annoying as it is not to be able to solve this logic conundrum, with BBC emulation having been a total pipedream a week ago I can live with that as the price of being able to play most of the classics, plus VIC-20 and Astrocade and Arcadia and maybe more :)

    (Although this is still driving me batty:)

    https://retropie.org.uk/forum/post/166438



  • I'm finding that the BBC Micro emulator is working well following most of the above, but it's forgetting a number of joypad controls (I'm using an Xbox controller with a Raspberry Pi). Does feel close though....



  • @OneSwitch Very occasionally it seems to forget mappings for Enter for no earthly reason I can ascertain.



  • Jeez, now there are more of them - it doesn't seem to want to retain mappings for closebrace (close square brackets) either, and MESS doesn't even have a setting for the F0 button, so it also won't save that.



  • @SpudsMcToole That's a pity. I've only got 4 games setup at present so haven't encountered that problem (albeit for some reason Elite simply won't work when I chain load it - I'll need to check whether it works with the run command instead).



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.