Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

RetroPie Freeze after couple of hours



  • i have raspberry 3b+ , So after a few hours my retro freeze and i need to power off and power on .
    i have it overclock -
    total_mem=1024
    arm_freq=1500
    gpu_freq=500
    core_freq=500
    sdram_freq=500
    v3d_freq=525
    sdram_schmoo=0x02000020
    over_voltage=8
    sdram_over_voltage=4
    temp_limit=80

    disable_splash=1
    avoid_warnings=1
    avoid_warnings=2

    Help anyone ?
    Thanks


  • Global Moderator

    @shavecat said in RetroPie Freeze after couple of hours:

    over_voltage=8

    yikes.

    anyways, if you have freezing, your overclock is almost certainly too aggressive. difficult to tell which particular part of the overclock is unstable as every board is different. i would take away all overclocks and then slowly reintroduce them until you get instability again.

    (although i wouldn't overclock at all as i think it's mostly pointless!)



  • @dankcushions said in RetroPie Freeze after couple of hours:

    over_voltage

    okay will try thanks.



  • still getting stuck .
    Weird cause the Temp' never going up from 60'.


  • Global Moderator

    @shavecat can you post your config.txt? remember you need to remove all overclocks, not just the over_voltage.

    it won't be a temperature issue. pi downclocks if the temperature gets too high. it will be a silicon limit issue.



  • @dankcushions
    okay so this is with no overclock -

    # For more options and information see
    # http://rpf.io/configtxt
    # Some settings may impact device functionality. See link above for details
    
    # uncomment if you get no picture on HDMI for a default "safe" mode
    #hdmi_safe=1
    
    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    disable_overscan=1
    
    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    #overscan_left=16
    #overscan_right=16
    #overscan_top=16
    #overscan_bottom=16
    
    # uncomment to force a console size. By default it will be display's size minus
    # overscan.
    #framebuffer_width=1280
    #framebuffer_height=720
    
    # uncomment if hdmi display is not detected and composite is being output
    #hdmi_force_hotplug=1
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1
    
    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    #hdmi_drive=2
    
    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    #config_hdmi_boost=4
    
    # uncomment for composite PAL
    #sdtv_mode=2
    
    #uncomment to overclock the arm. 700 MHz is the default.
    
    # Uncomment some or all of these to enable the optional hardware interfaces
    #dtparam=i2c_arm=on
    #dtparam=i2s=on
    #dtparam=spi=on
    
    # Uncomment this to enable the lirc-rpi module
    #dtoverlay=lirc-rpi
    
    # Additional overlays and parameters are documented /boot/overlays/README
    
    # Enable audio (loads snd_bcm2835)
    dtparam=audio=on
    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=256
    overscan_scale=1
    gpu_mem=512
    
    
    kernel=kernel3g1g.img
    
    

  • Global Moderator

    @shavecat said in RetroPie Freeze after couple of hours:

    gpu_mem=512

    that setting is pointless btw: https://retropie.org.uk/docs/Memory-Split/

    buuuut, everything else seems fine. if you're still getting instability, it is most likely a bad PSU or cable problem.



  • @dankcushions said in RetroPie Freeze after couple of hours:

    cable

    Cable !
    order new one online ...
    thanks a lot :)


  • Global Moderator

    @dankcushions I think @shavecat posted the default config.txt, not the one used to overclock..



  • Notice the usage of a custom kernel in the posted configuration:

    kernel=kernel3g1g.img
    

    Perhaps would be recommendable to switch to the stock kernel to discard that factor.


  • Global Moderator

    @hhromic Not really sure that's the culprit, that's the kernel image used to get Wine working - see the (rather recent) Diablo-on-Wine-on-Retropie thread. But for a 3B+ it might be a factor, given the frequent updates added by the Raspbian team to stabilize it on this new model.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.