Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Cannot configure Mayflash F300 Joystick



  • Pi Model or other hardware: Raspberry Pi 3 Model B
    Power Supply used: Official Raspberry Pi™ Foundation 5V 2.5A Power Supply
    RetroPie Version Used: 4.4.3
    USB Devices connected: XBOX360 Controller Dongle, XBOX360 Controller, Keyboard, PiHut USB Hub

    Hey all,

    I, for the life of me, cannot get my Mayflash F300 Joystick to work with my Pi. I have tried everything from this thread (https://retropie.org.uk/forum/topic/12150/mayflash-f500-configuration-problem/5) to going with the nuclear option and trying to reset my entire controller config (https://github.com/RetroPie/RetroPie-Setup/issues/1349).

    I leave the d-input button down, along with the D-PAD button. I go to map the joystick, hold down a button, and it's recognized as a Mayflash F300 Joystick.

    BUT Retropie will not recognize D-PAD right and while I can map the buttons, when I go back to the menu the thing goes haywire and I am stuck.

    It's working fine with everything else like PS4 etc, so it's not the joystick.

    Please help



  • What 'mode' is the gamepad on - PC/PS/Xbox ? The topic you mentioned recommends setting the stick in 'Dinput' mode for the PC. Have you tried to set it in XInput mode ?



  • I got this to work..its weird...I set it at dinput, and x/y and the thing just mapped (now the stick is mapped to Y-1, X-0)


 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.