Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Sf30 pro 2nd player not working



  • Hi,
    Just received my system yesterday and also received two 8bitdo sf30 pro controllers. I have configured the two controllers, however, when I play contra with 2 players the 2nd controller will not shoot. I can run around, lay down, jump, etc. But the B button just does not work. I safely turned off the system and tried it again but it still didnt work. I re-configured the controllers again just in case I messed up, but nope, still the same issue. Does anyone have a solution for this issue? If it matters, the console came with 2 wired controllers that i played with prior with no Issues while the sf30 pros were charging...
    I am running raspberry pi 3b+ with retropie 4.4.....


  • Global Moderator

    @DirtyHarry1252 Open the RGUI with Hotkey + X (Select + X) and then check the 2nd Player mapping in the Input section of RetroArch. Does it have a button assigned ?



  • @mitu thank you for replying, I will check on this when I get a chance after work.



  • @mitu
    I cannot find 2nd player mapping in the input section.
    The list in the input section looks like this :
    Max users: 5
    Unified menu controls: on
    Poll type behavior: late
    Menu toggle gamepad combo: none
    Menu swap ok 8 cancel B...... : off
    All users control menu: on
    Analog stick dead zone: .500
    Input hotkey binds: .....
    Input user 1 Binds: .....
    Input user 2 Binds: .....
    Input user 3 Binds: .......
    Input user 4 Binds: ......
    Input user 5 Binds: ......

    Also, when I plug in the wired controllers I have no issue. I also just double checked and noticed its 1st player and not the 2nd player. Instead of shooting with B he jumps, and the A button which is normally the jump button does nothing. I also turned off the system and turned it back on swapping the sf30 controllers position on who is 1st player and who isn 2nd player. It turns out that whichever is 1st player has this issue, it's not a specific controller......


  • Global Moderator

    @DirtyHarry1252 The gamepad configuration for Player X is under the Input user X Binds.
    When you use the controllers wired, they have a different configuration. I'd advice to

    • reset the input configuration - from Retropie Setup Script >> Manage Packages >> Manage Core Packages >> EmulationStation >> Configuration / Options >> Clear / Reset EmulationStation Input Configuration
    • remove any paired Bluetooth controllers from the Bluetooth menu
    • start the controller (one of them) in Android mode
    • re-pair the controller via Bluetooth, then configure it in Emulationstation
    • pair the 2nd controller via Bluetooth

    Restart the system, restart the controllers also and see if the problem persist.



  • @mitu so I followed your detailed instruction step by step and it still didnt work. Is there a way to configure the controllers specifically for each system? It seems like the buttons change when i switch video game systems. Like when I go into the n64 section more buttons work but to exit the game and to get back to the retropie main screen I have to hold down l2 and r2 instead of select and start. I also tried twisted metal 2 on playstation and some of the buttons didnt work. I appreciate your help so far!



  • @mitu ohh, wait I didn't start it in android mode. Just found out how to do that through my controller instructions. I will try again tomorrow lol



  • @mitu
    So I never knew it but the controllers needed to be updated to the newest firmware so I thought that might be the problem as well. So I updated them and tried your guide step by step. It helped but didnt fix it all the way. For instance, Contra 2nd player shoots with A and jumps with B. 1st player shoots with A but jumps with Y. It's not so bad playing it like that but those button layouts make it difficult to play other games such as super Mario world 3. Is there something in retroarch I need to configure as well besides the emulstation?


  • Global Moderator

    @DirtyHarry1252 Are those 2 controllers identical or not ? My advice was based on them being identical so you only need to configure one of them once and the 2nd one will work as-well (with the same mapping scheme). In RA, once you're in the RGUI you can got to the player binds (as you noticed earlier) and change them there.



  • Are they in the same mode? Sounds like you got a mismatch there. I play both mine on Switch mode (Start+Y).



  • @cebix yes they are both on switch mode. Start y or just start.



  • @mitu yes they are the exact sf30 pro controllers and I just went into retroarch and went to player binds and configured it there as well and I'm still having the issues.



  • After giving up on the sf30 pros I plugged my two wired snes controllers in and the problem persists with only the first player. So what I've noticed is 1st players b button does not work at all. Like in contra it does nothing and in super mario world it does nothin. But second player works fine.


  • Global Moderator

    Did you modify any of the configuration files for the emulators ? Are you using an 'official' RetroPie image or a 3rd party image ?



  • @mitu I got it off ebay as a plug in and play. I didnt set anything up by my self. So I dont really quite understand the image thing you are talking about and I don't think I configured anything else from what we have talked about


  • Global Moderator

    @DirtyHarry1252 We don't support 3rd party images, especially the ones sold (with ROMs). RetroPie image's license is non-commercial, so you've got scammed - RetroPie is free.

    If you wish to pursue this further and have support here, please install the image from retropie.org.uk/download using the instructions from the documentation. If you still have problems with your controllers, then feel free to post here a new topic asking for support.



  • @mitu I'll contact the seller but I'm pretty sure it's not a 3rd party image they have hundreds of great reviews. I didnt buy retropie, I bought a console with everything set up for me... There's gotta be some sort of setting that was set up wrong that I can fix. I'm a newbie to retropie and raspberry pie so at the moment I have no clue how to fix it
    . Thanks for trying to help me though


  • Global Moderator

    @DirtyHarry1252 This so called 'seller' is a scammer. As I said, it's illegal - per the RetroPie license - to sell RetroPie preloaded. You didn't buy a 'console', but merely an illegal product profiting from RetroPie and other open source projects that support emulation.



  • @mitu never knew that, hmmmmmmmm. Thanks for the heads up



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.