Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Keyboard/Controller not working Pi Zero W and Retropie 4.4



  • I am having a strange issue. I image my SD card with Retropie 4.4 (I have also tried 4.3 and 4.2 with the same results) and when it loads Emulation Station, it does not detect my keyboard or controller. I have a Makerspot HAT 4 port hub. Strange thing is, if I install Raspbian Stretch (lite and full) on the SD card instead, the keyboard works fine. What would be my issue? I have tried various power supplies from 2400mA to 2.5a with the same results. I have also tried different external usb hubs with the same results with retropie and Raspbian. So it appears that Retropie is the issue. I was able to SSH in and when I do a lsusb, I can see the 2 onboard usb ports, my 4 port hub and both the keyboard and controller. Sometimes Retropie will not even boot up correctly when a keyboard or controller is plugged in. The keyboard will respond to NUM lock presses until it fully boots. so only in the early stages of booting does it seem like it is working.

    Thanks in advance!



  • @jladd1113 Try updating the 4.4 image with the latest OS packages, that would the only difference between the 2 images. If that doesn't work, then you can manually install RetroPie ontop of Raspbian - https://retropie.org.uk/docs/Manual-Installation/.


 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.