Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Anyone having trouble installing/using the recent Steamlink package in RetroPie? Can't install from binary (only option)



  • So I've updated eveyrthing, so that doesn't seem to be the issue. Can update and run other packages as norm, but today I heard about the Steamlink option for Retropie and was very excited as its something I think I would use a lot. Watched and read about install, seems pretty strightforward but when I attempt to install from binary it starts to, unpacks and runs through some installation lines but then ends and gives me a 'unable to install from binary' message. I checked the logs, and find "Unable to locate package steamlink Unable to install binary for steamlink". Is this on their end, as in something isn't located corrected or is it something on my pi that is causing the problem. Connection is fine. Any thoughts?


  • Global Moderator

    @moltke44 Please add more info about your system, as requested in https://retropie.org.uk/forum/topic/3/read-this-first. There is also a more detailed log file in the ~/RetroPie-Setup/logs folder, you can take a look in it to see the actual error.



  • Sorry about that, I did attempt to search sorry for post formatting sloppiness. Here is some more info.

    Pi Model or other hardware: (3)
    Power Supply used: (CanaKit 2.5A USB Power Supply)
    RetroPie Version Used (4.4.4):
    Built From: (Pre made SD Image on RetroPie website)
    USB Devices connected: None
    Controller used: PS3
    Error messages received:
    Full Log text:

    "Log started at: Sun 30 Dec 14:07:59 UTC 2018
    RetroPie-Setup version: 4.4.4 (72e2d2b)
    System: Linux retropie 4.9.35-v7+ #1014 SMP Fri Jun 30 14:47:43 BST 2017 armv7l GNU/Linux

    = = = = = = = = = = = = = = = = = = = = =
    Installing dependencies for 'steamlink' : Steam Link for Raspberry Pi 3
    = = = = = = = = = = = = = = = = = = = = =

    = = = = = = = = = = = = = = = = = = = = =
    Installing 'steamlink' : Steam Link for Raspberry Pi 3
    = = = = = = = = = = = = = = = = = = = = =

    Reading package lists...
    Building dependency tree...
    Reading state information...
    E: Unable to locate package steamlink
    Unable to install binary for steamlink

    Log ended at: Sun 30 Dec 14:08:02 UTC 2018
    Total running time: 0 hours, 0 mins, 3 secs

    Hope that helps,



  • @moltke44 Perhaps a sudo apt-get update before you try will help?


  • Global Moderator

    @moltke44 Steamlink is not compatible with the Raspbian version you're running. You need Raspbian Stretch - latest Raspbian version - but you're running Raspbian Jessie. You'll need to install the 4.4 RetroPie image released this spring to get the latest Raspbian version.

    The Steam Link app is now available in beta on the Raspberry Pi 3 and 3 B+ running Raspbian Stretch.



  • So no update method available from within my image with Jessie? I see a few threads mentioning this, but the method they list is treated like it would likely ruin or corrupt the pi its tried on. Another user post (as well as Swampy above) mentioned trying the commands.

    sudo dkpg --configure -a
    sudo apt-get update


  • Global Moderator

    @moltke44 You can try any command you see fit, but the package will not work under Jessie - even if you get it installed.
    As for the update to Stretch, the recommended method is to use a new image from scratch and transfer your configs/roms/etc. to the new image. It's possible - technically - to upgrade in place, but as you already found, it's not always optimal and you can end up re-imaging anyway.
    Remember to backup your image before attempting the upgrade - with any method you choose.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.