Please do not post a support request without first reading and following the advice in

Ive messed up my controls in games and retroarch...

  • Hello,

    My name is Dayle and i am new to the scene. I recently purchased a R Pie 3B+ and installed the latest Retropie software. I use an Xbox one controller via Bluetooth which has been working fine with all the emulators and inside Retroarch itself up until yesterday.

    This is where i think its gone wrong; I noticed that the PSX buttons wasn't quite right. For instance my "B" button was triggering the playstations "Cross" button so i started to look into changing the maps by core. As a result i can no longer control any of my games as all the buttons are all over the place. I cant even get to Retroarch by using the Hot key + X method. I can however get to Retroarch from Emulation station but once I'm in a can not move up or down or select any menu's. The only way i can get out is by unplugging the power.

    I can navigate Emulationstation fine and even when i reconfigure my controller i still have the same results in games and Retroarch.

    Any ideas?

  • Global Moderator

    @hallda12 Reset your controller configuration - - and then re-map your controller again. When re-mapping your buttons from RetroArch, use the Core input mapping option and not Save Configuration.

  • @mitu Ok ill try that later. So far i tried deleting the retroarch.cfg file but that didnt work. It did however change the display of the retroarch GUI. It changed it to a PS4 themed display where as before it was a green list view 8-bit type theme. Do you know why this might happen.

  • @hallda12 In the directory where you deleted the retroarch.cfg there should be a file called retroarch.cfg.rp-dist. Make a copy of that and rename the copy to retroarch.cfg.

    The XMB GUI that you're seeing is actually the RetroArch default used on platforms like full-blooded gaming PCs but it's a bit of a resource hog, so the RetroPie team used the most recource-conservative theme there was.

  • @mitu Ahh makes sense. In your experience does the default GUI effect gameplay or anything on the R Pie 3B+?

  • Global Moderator

    @hallda12 I think you meant to reply to @ChaosFox. The GUI does no affect gameplay, since it's only mean to be shown for configuration - RetroPie uses Emulationstation so you're not seeing or using it much.

  • @ChaosFox Thanks for the info!

    @mitu Yes sorry that was meant for Chaos. So really I'm safe to keep the Default GUI as it only effects performance when its being displayed?

  • @mitu Ok ive tried what you suggested by resetting the input file and then remapping my controller. I can now play games again however the buttons seem to be all wrong. My start button does nothing and Hotkey + X doesnt bring up Retroarch. For some reason my Select button seems to launch retroarch...

  • Global Moderator

    @hallda12 You probably mapped the gamepad's Select button on the Start button in Emulationtation.

  • @mitu But isnt the shortcut meant to be Hotkey + X, not just select/start on its own. I'm almost certain my map is correct. Its almost like Retroarch thinks my Xbox controller is something different.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.