Please do not post a support request without first reading and following the advice in

Unknown Freeze in the ES menu.

  • Hello, I am Marpet. And, let me just get straight to the chase. I have been using Raspberry Pi 3b+ for quite a while. While i have tried to ignore it, but it has slightly started to get a little bit annoying. Whenever in the menu of emulationstation, the menu tends to freeze up for a second before registering my input and everything else (Using a keyboard).

    I have reinstalled Retropie image on micro sd card countless times. I am using NESPi case, in which before i do anything else, is to install the safe-shutdown script. (To have the ability to turn off the Pi without corrupting SD Card from the button on the NESPi-case).

    Now for a little background story, When i got my Pi, i didn't use the official charger for the pi. Which caused the Pi to have under-voltage issues. I used different types of chargers, which might have been bad, but soon as i found out that there is an official charger, i went out to buy one. And that fixed the under-voltage issue.

    But now comes the interesting part; The emulationstation freezes up in the menu, and it may have also happened once in the emulators themselves, and the Retropie OS was on a 8GB MicroSD. So, i bought my myself a ''pre-installed NOOBS OS'' Sd card to test something. And well, that seemed to run just fine. So that implies that there is nothing wrong with the Pi itself. Well, The mouse seems to have quite the delay. Very very strange delay. But that's not the main issue, since i am mostly just going to use the Pi for retro gaming.

    Could the 8GB SD Card have been some sort of semi-corrupted during the Under-Voltage warning? Or does it have somethig to do with the Retropie Image itself? Have anyone else experienced this?

    And i also want to point out that i have been using an USB stick to play games, but i am not sure it that is the cause, since i have tried starting Pi without any sort of USB stick.

  • Global Moderator

    @marpet0805 Can you try to see if the issue occurs without the PI in the NESPi case ? Pull it out and see if you get the same problems. Are you using the default theme (Carbon) or another one ?

  • @mitu Yes. I am using the originial pre-installed theme that comes with the RetroPie, the black/red-ish theme. But, i did as what you suggested, I took out the Pi from the case, unplugged all the stuff from the nespi case and took out the pi and tested starting up just from the pi. And now it seems to running fine without any freezing. But now it brings more questions.

    It's strange. If the NESPi case is what causes it to freeze, i wonder why does it. This is probably not the right place for me to ask i assume?

    Because it ran fine with an another os while the pi was in the NESPi case.

    Oh, and i forgot to mention that i had a seperate fan inside the NESPi case while the Pi was in there, the NESPi has a seperate board that small fan can plug into. Maybe it demands more voltage? I have no clue.

  • Global Moderator

    @marpet0805 The NESPi cases are notorious for under-voltage - even when using the official power source - and USB connection problems, since the case has its own PCB/wires.

  • @mitu I see. I understand. Thank you for the help. I will see if i can find an alternative to NESPi case. Well, the biggest reason i got it was because of the Safe Shutdown script. Pressing a button to turn off the console is neat, so i can prevent any corruptions to the SD Card.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.